Mailinglist Archive: opensuse (1231 mails)

< Previous Next >
Re: [opensuse] GRUB2 hell
On 06/03/13 20:37, Istvan Gabor wrote:
2013. március 6. 9:51 napon Basil Chupin <blchupin@xxxxxxxxxxxx> írta:
, Basil Chupin <blchupin@xxxxxxxxxxxx>, "Basil Chupin" <blchupin@xxxxxxxxxxxx>
On 06/03/13 19:30, C wrote:
On Wed, Mar 6, 2013 at 7:07 AM, Basil Chupin wrote:
I then installed kernel 3.8.2-1 on oS 12.3 RC2 (sda5) - and now I cannot

All the parameters in the bootloader(s) appear to be OK except when I go to
boot into "safe mode" in 12.3 (sda5) I get the error message:

Invalid Magic number.

What the f*** is "Invalid Magic number"?! *WHAT* number?! Of all the
lame-brained, inane, stupid, meaningless error messages to have ever existed
this one MUST take the cake! I think this beats whatever Windows ever
managed to come with - and that's saying something.
Magic number dates way way back into the medieval perios of Unix.
Originally some variable that was nicknamed "magic number". It now is
generally used to reference a valid filetype or filesystem type.

There is a fairly comprehensive explanation of it here:

I don't have a good suggestion for recovery - guessing... something
broke when installing the new kernel. vmlinuz is wrong? the new
kernel image is invalid? Is it only on 12.3RC2 or all installs?
Thanks, C. I'll read the wikipedia entry later - I've had enough of
searching the net for an explanation (but, strangely enough, the
wikipedia entry did not turn up; obviously an incorrect search string on
my part).

And Yes, it is only on the RC2 installation as I mention in my post.

Using the Compare File option in mc I did compare vmlinuz between 12.2
and RC2 and they are *identical*.

The only file which was different was intird but even after copying over
the one for 12.2 over to RC2 the same error msg comes up.

The only way I can see out of this is to either-

boot into RC2 and re-install the kernel; or

re-install RC2

But with RC2 all there and functioning except for the grub2 boot process
I would rather not re-install unless absolutely necessary.



I have never worked with grub2 therefore this even might not be appropriate
(I don't know how grub2 works compared to grub(1)).

Thanks for you response.

I have found that working with grub2 is as easy as working with grub. But it does require some acclimatisation. But it is NOT as mind-boggling as some people make it out to be.

Just an idea:
Earlier I had boot problems as well and it turned out that one of the stage
had problems. I had to reinstall grub using grub shell to fix it.
(grub stage images are copied from /usr/lib/grub/ to /boot/grub when grub
is installed, in case of grub1.)

To begin, using grub2 everything is now "grub2-<somecommand>" :-) . That's the first and the most easiest thing to come to grips with - everything else remains basically the same.

I've looked at what you wrote and found that what is in usr/lib/grub2 is NOT totally copied over to /boot/grub2. I don't know what the process is but 50% of the files are copied over and given the date that they were created in /boot/grub2.

But, of course, my problem at the moment is that I am unable to boot into 12.3 RC2 (on sda5) to be able to use any of the grub2 commands or to re-install the kernel.

I read a few minutes ago that 12.3 is almost ready so I think that I will wait for this and install this.


Using openSUSE 12.2 x86_64 KDE 4.10.00 & kernel 3.8.2-1 on a system with-
AMD FX 8-core 3.6/4.2GHz processor
16GB PC14900/1866MHz Quad Channel Corsair "Vengeance" RAM
Gigabyte AMD3+ m/board; Gigabyte nVidia GTX550Ti 1GB DDR5 GPU

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups