Mailinglist Archive: opensuse (924 mails)

< Previous Next >
Re: [opensuse] incorrect xorg setup in openSUSE 12.1
2012. október 11. 19:45 napon Felix Miata <mrmazda@xxxxxxxxxxxxx> írta:

Felix, I compared the commands you suggested both in openSUSE 11.2
and openSUSE12.1 systems.

In openSUSE 11.2 (where the display is set correctly) I get:

# cat /etc/SuSE-release
openSUSE 11.2 (i586)
VERSION = 11.2

# lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon
7000/VE]

# lsmod | sort | grep radeon
#

# head -n8 /var/log/Xorg.0.log

X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux xx 2.6.37-desktop #1 SMP PREEMPT 2011-01-11
16:25:30 +0100 i686
Build Date: 23 September 2010 03:43:55PM

# grep Chipset /var/log/Xorg.0.log
(--) RADEON(0): Chipset: "ATI Radeon VE/7000 QY (AGP/PCI)" (ChipID = 0x5159)

# grep 1600x /var/log/Xorg.0.log
(**) RADEON(0): Option "PreferredMode" "1600x1200"
(II) RADEON(0): Panel infos found from DDC detailed: 1600x1200
(II) RADEON(0): Output DVI-0 using initial mode 1600x1200
(II) RADEON(0): Modeline "1600x1200"x0.0 162.00 1600 1664 1856 2160 1200
1201 1204 1250 +hsync +vsync (75.0 kHz)
(II) RADEON(0): Modeline "1600x1200"x0.0 162.00 1600 1664 1856 2160 1200
1201 1204 1250 +hsync +vsync (75.0 kHz)
(II) RADEON(0): Modeline "1600x1200"x0.0 162.00 1600 1664 1856 2160 1200
1201 1204 1250 +hsync +vsync (75.0 kHz)
(II) RADEON(0): Modeline "1600x1200"x0.0 162.00 1600 1664 1856 2160 1200
1201 1204 1250 +hsync +vsync (75.0 kHz)
(II) RADEON(0): Modeline "1600x1200"x0.0 162.00 1600 1664 1856 2160 1200
1201 1204 1250 +hsync +vsync (75.0 kHz)
(II) RADEON(0): Modeline "1600x1200"x0.0 162.00 1600 1664 1856 2160 1200
1201 1204 1250 +hsync +vsync (75.0 kHz)



In openSUSE 12.1 (where display is not configured correctly) I get:

# cat /etc/SuSE-release
openSUSE 12.1 (i586)
VERSION = 12.1
CODENAME = Asparagus

# lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon
7000/VE]

# lsmod | sort | grep radeon
#

# head -n8 /var/log/Xorg.0.log
[ 390.249]
X.Org X Server 1.10.4
Release Date: 2011-08-19
[ 390.249] X Protocol Version 11, Revision 0
[ 390.249] Build Operating System: openSUSE SUSE LINUX
[ 390.249] Current Operating System: Linux xx 3.1.10-1.16-desktop #1 SMP
PREEMPT Wed Jun 27 05:21:40 UTC 2012 (d016078) i686
[ 390.249] Kernel command line: root=/dev/disk/by-id/xxx-part1
resume=/dev/disk/by-id/xxx-part5 splash=silent quiet vga=0x317
[ 390.255] Build Date: 10 November 2011 03:34:02PM

# grep Chipset /var/log/Xorg.0.log
[ 390.416] (--) RADEON(0): Chipset: "ATI Radeon VE/7000 QY (AGP/PCI)" (ChipID
= 0x5159)

# grep 1600x /var/log/Xorg.0.log
[ 390.429] (**) RADEON(0): Option "PreferredMode" "1600x1200"
[ 390.595] (II) RADEON(0): Panel infos found from DDC detailed: 1600x1200
[ 390.595] (II) RADEON(0): Not using mode "1600x1200" (mode clock too high)
[ 404.729] (II) RADEON(0): Modeline "1600x1200"x0.0 162.00 1600 1664 1856
2160 1200 1201 1204 1250 +hsync +vsync (75.0 kHz)
[ 407.775] (II) RADEON(0): Modeline "1600x1200"x0.0 162.00 1600 1664 1856
2160 1200 1201 1204 1250 +hsync +vsync (75.0 kHz)

I guess this line explains:
[ 390.595] (II) RADEON(0): Not using mode "1600x1200" (mode clock too high)

But why 12.1 thinks that mode clock too high?

Thanks,

Istvan

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups