Mailinglist Archive: opensuse (924 mails)

< Previous Next >
Re: [opensuse] incorrect xorg setup in openSUSE 12.1
On 2012-10-10 19:08 (GMT+0200) Istvan Gabor composed:

I had to replace my nvidia card to an older ATI radeon 7000.
Since I use xorg.conf for configuring X, the X window system
could not be started with the new card.
In openSUSE 11.2 this was not a problem at all: I started sax2
in a terminal and it configured X properly according to my display's
native resolution, 1600x1200.
In openSUSE 12.1, as it does not have sax2, I removed the old xorg.conf,
and expected that the system configures X correctly. But instead
of the native 1600x1200 resolution the result was 1280x960.
You can imagine how 1280x960 looks on a 1600x1200 display: ugly.

Obiously openSUSE 12.1 can not automatically configure X correctly,
while in 11.2 the correct configuration could be done easily.

You might have a cable or radeon 7000 connector problem interfering. Or maybe your display's preferred mode and available modes are out of sync with your understanding or wishes. Is it a CRT?

Next I copied the xorg.conf file from 11.2 to 12.1 but this did not
make any change on resolution, it is still 1280x960.
Now I am stucked, what should be the next step to correct this?

1-Remove /etc/X11/xorg.conf
2-match the content of the following files:
/etc/X11/xorg.conf.d/50-device.conf
/etc/X11/xorg.conf.d/50-monitor.conf
/etc/X11/xorg.conf.d/50-screen.conf

to:

http://fm.no-ip.com/Tmp/Linux/Xorg/50-device.conf
http://fm.no-ip.com/Tmp/Linux/Xorg/50-monitor.conf
http://fm.no-ip.com/Tmp/Linux/Xorg/50-screen.conf

and you'll probably be good to go. They work with my rv200 Radeon 7500.
--
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
References