Mailinglist Archive: opensuse (818 mails)

< Previous Next >
Re: [opensuse] openSUSE flaunting GPL
On Sun, Jul 15, 2012 at 10:43:55AM -0700, Linda Walsh wrote:
Seems like openSUSE doesn't bother to include sources anymore for
building their packages.

Since no one seem to care about the bug in the spec-file for samba-3.6.3
causing it's build
to fail, the fact that perl5.14.2 doesn't build is become evidence of a
pattern.

The spec file has a requirement on a package 'db-devel', yet there is no
such package.

Presumably it would include the necessary /usr/include/db.h file that
defines the dbm_open
call needed for perl5 to build as well.

Doesn't this violate the GPL that allows suse's software to be licensed
under the GPL?

No, its not a pattern... Its just that "rpmbuild" and the "osc build" process
act a tad bit different.

osc build pulls in exactly the set of buildrequirements specified and nothing
more.

libdb-4_8-devel has:
Provides: db-devel = %{version}

and samba probably doesn't build because you have too much builddeps installed
or similar.

CIao, Marcus
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups
References