Mailinglist Archive: opensuse (818 mails)

< Previous Next >
Re: [opensuse] oS12.1 starts only in failsafe mode
On 2012/07/06 05:22 (GMT-0400) Oszkó Albert composed:

After the last software update, oS starts only in the failsafe mode,
normal (auto) login gives only a prompt, and I can log into the command
line. I suspect, the cause is the newly installed fglrx-xpic driver.

It sounds like for future troubleshooting you need a Grub menu with choice to use a previous kernel but don't have it. Before next updates and/or new kernel installation you should remove "##" from the line containing "multiversion = provides" in /etc/zypp/zypp.conf.

After unistalling it, the system start, but the widgets are moved to
another place in the screen. Executing startx from command line gives

For startx to work you need to remove the # from the last line in /etc/permissions.local and run 'SuSEconfig --module permissions'.

fatal error about setting setuid, ata_piix and some other, but they
disapper too fast.
How can I go back to normal operation?

oS 12.1 32 bit, KDE 4.8.4, ATI Radeon HD 4350

A big difference between failsafe and regular Grub menu choices is nomodeset, which you can change/add/delete on the fly in the Grub GFXmenu.

With the latest fglrx and kernel installed, nomodeset was (and is) probably missing from the default menu entry. You'll need to share your Xorg.0.log for most help here, but first read the following:

http://en.opensuse.org/SDB:Radeon
http://en.opensuse.org/SDB:ATI_troubleshooting
--
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
References