Mailinglist Archive: opensuse (818 mails)

< Previous Next >
[opensuse] Python Scripting Failure after LibO 3.4->3.5 Upgrade (SuSE 12.1 x64)
Hi !

After upgrade from LibO 3.4 to 3.5 (on SuSE 12.1 x64) all my Python macros have
stopped working with very long error message (below).

All my Python scripts located in the same location as before:
~user/.libreoffice/3-suse/user/Scripts/python/

At a glance, looks like LibO python module can't properly locate scripts
anymore for whatever reason (maybe internal API changes I'm not aware of).

Anyone can suggest me what might go wrong?

Thanks in advance.

********************************
Error Messagee

********************************

BASIC runtime error.
An exception occurred.
Type: com.sun.star.script.provider.ScriptFrameworkErrorExceptionMessage: <class
'uno_component.com.sun.starucb.InteractiveAugmentedIOException'>: an error
occured during file opening

/usr/lib64/libreoffice/share/extensions/script-provider-for-python/pythonscript.py:376
in function getModuleByURL() [lastRead = self.sfa.getDateTimeModified(url)]

/usr/lib64/libreoffice/share/extensions/script-provider-for-python/pythonscript.py:900
in function getScript() [mod = self.provCtx.getModuleByUrl(fileUrl)]

********************************--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages