Mailinglist Archive: opensuse (818 mails)

< Previous Next >
Re: [opensuse] bind DNS: forwarders not working unless named is restarted
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Wed, 04 Jul 2012 11:44:33 +0200
  • Message-id: <jt13a1$lso$1@saturn.local.net>
lynn wrote:

On 04/07/12 07:57, Per Jessen wrote:
lynn wrote:

On 03/07/12 20:31, Per Jessen wrote:

Hi Per, hi everyone

I guess you know forwarding is broken because your queries aren't
forwarded to the _right_ nameservers? I mean, you have a special
reason for needing to use the dragonet.es nameservers?

Only that it would relieve our own servers.

Okay.

I think it would be good to verify if forwarding happens or not (use
tcpdump) and then do a "dig <something>", then "dig +trace
<something>" that will require forwarding. That ought to give us
something to start on.


It looks as if our servers are doing it all (192.168.1.2 is the DNS on
DC1):

dig google.es

[snip - worked fine]

dig +trace google.es

[snip - no forwarding happened]

/etc/named.conf
options {
directory "/var/lib/named";
managed-keys-directory "/var/lib/named/dyn/";
forwarders { 217.70.240.135; 217.70.240.136; 192.168.1.3; };

plus default "forward first". Looks fine.

So, once you restart bind, forwarding to dragonet.es works? How does
that look with "dig +trace google.es" ?


--
Per Jessen, Zürich (20.6°C)

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups