Mailinglist Archive: opensuse (1445 mails)

< Previous Next >
Re: [opensuse] Missing search engines in firefox 11.99-4.1
Am 26.03.2012 23:58, schrieb Andrea Turrini:
On 26/03/12 23:43, Andrea Turrini wrote:
On 26/03/12 23:15, Wolfgang Rosenauer wrote:
But it's most likely language dependent. What is your FF UI language?

English; more precisely:

I went into the problem thoroughly and I do not think it is something
related to language.

Thanks for checking. You just found the proof that it's about languages ;-)

I tried to extract using mc the -2.1 and the -4.1 rpms in m2 and m4,
respectively, and I obtain the following:

ori@orodruin:~> grep -ri Bing m2 m4
Binary file m2/usr/lib64/firefox/libxul.so matches
Binary file m2/usr/lib64/firefox/omni.ja matches
Binary file m4/usr/lib64/firefox/libxul.so matches
ori@orodruin:~> grep -ri google m2 m4
Binary file m2/usr/lib64/firefox/libxul.so matches
Binary file m2/usr/lib64/firefox/omni.ja matches
Binary file m4/usr/lib64/firefox/libxul.so matches

Consider that I erased the -4.1 rpm from zypp cache and forced its
reinstall (after downloading it again).

So there is a difference in the omni.ja file: if I replace the omni.ja
from -4.1 with the one from -2.1, all search engines are available again.

It works for every locale but EN actually.
The searchplugins are indeed part of the locale packages (in the
openSUSE RPMs). They are not packaged for en-US (which is part of
omni.ja instead of a separate locale pack). That's why it didn't look
like locale issue for you.

I need to look into it. There was some change in the Makefiles in locale
pack generation which I adapted the locale pack generation for but I
missed the fact that I need to do something for omni.ja as well apparently.


Wolfgang
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups