Mailinglist Archive: opensuse (1445 mails)

< Previous Next >
Re: [opensuse] cannot reboot [was Re: Radeon HD 6450]
On 2012/03/11 19:43 (GMT-0400) Michael Fischer composed:

Ok, I removed the xorg.conf and set the /etc/X11/xorg.conf.d/50-device
to use 'Device: "radeon"'. Now I get

(EE) RADEON(0): Chipset: "CAICOS" (ChipID = 0x6779) requires KMS

off to reboot without the 'nomodeset'

1-For 50-device.conf to work you also need properly uncommented sections in 50-monitor.conf and 50-screen.conf, at least in every case I've tried to use xorg.conf.d/.

2-nomodeset on cmdline prevents the radeon driver from working at all. Radeon requires working KMS.

... ok, now I'm back to being unable to boot:

mdadm: an md device must be given in this mode
...
/dev/md0: the superbblock could not be read or does not describe a correct ext2

off to try to reinstall that partition..

Boot messages are often in a misleading order as long as you're using systemd and/or "YES" for RUN_PARALLEL= in /etc/sysconfig/boot. This also may be a problem that goes away if not using systemd init. You can per boot or permanently not use it via instructions in the relnotes: http://www.suse.de/relnotes/i386/openSUSE/12.1/RELEASE-NOTES.en.html
--
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >