Mailinglist Archive: opensuse (1698 mails)

< Previous Next >
Re: [opensuse] [SOLVED] "Undefined mode 348"
On 21/12/11 20:16, Brian K. White wrote:
On 12/20/2011 11:07 PM, Basil Chupin wrote:
I have just replaced my monitor and the video card.

Now, suddenly, when I boot the computer I get the error message:
"Undefined mode 348" and am given the option of selecting a video mode
to continue the boot (and I select '31A' which gives me 1280x1024).

In menu.lst the entry for the boot video mode is 'vga=348' (and has been
for years) which equates to a resolution of 1440x900.

The monitor supports this resolution of 1440x900.

Does anyone know, please, in which 12.1 oS file the video resolutions
are defined so that I can check if '348' is there?

(There were some upgrades done this morning and I wonder if one of them
produced this change?)

BC


It's a video card bios thing. The new video card either does not support that mode, or it needs special setup (every boot, post-boot) before it can support that mode (http://915resolution.mango-lang.org/), or the resolution you want is arrived at by setting some other mode number.

Hopefully you don't have a KMS problem.

Start with this. Hopefully the cards bios and the kernel driver already natively support the mode you want, and you just need to list all modes and edit your menu.lst to use whatever the new mode number is that has the resolution you want.
https://wiki.archlinux.org/index.php/GRUB#Graphical_boot


Otherwise, it depends on what version of suse you have and what kind of chip the new video card has and whether or not you can use open source or proprietary drivers.

Google for kms and and drm

https://wiki.archlinux.org/index.php/Intel#KMS_.28Kernel_Mode_Setting.29
I don't know where the good equivalent docs are for suse if any exist.
They don't turn up from googling "opensuse kms".
All I get are forum posts and http://www.novell.com/linux/releasenotes/x86_64/openSUSE/12.1/#08

Sorry I don't have explicit details.

I happen to have used 1440x900 several times myself and I don't remember ever using 348 as the video mode, so I'm guessing that was actually a card-specific and/or hack mode and the new card needs a similar but different hack, or has that mode natively instead of needing a hack, but it isn't at 348.

Many thanks, Brian. The problem solved by using 'hwinfo --framebuffer' as mentoned in the wiki.archlinux linux above.

It was indeed the video card which did not support the resolution 'vga=348' which, incidentally, was the hex number which openSUSE came up with when I installed 12.1 and it is for 1400x1050 for the card I had previously used.

I had searched the 'net for a solution to my problem but what I did read was more confusing than informative. I have now bookmarked the wiki.archlinux URL for future reference. It is a pity that oS doesn't have a similar site or one such as Launchpad for Ubuntu.

Thanks again.

BC

--
There are actually three kinds of mind: one kind grasps things unaided, the
second sees what another has grasped, the third grasps nothing and sees nothing.
Niccolo Machiavelli


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups