Mailinglist Archive: opensuse (1698 mails)

< Previous Next >
Re: [opensuse] Systemd and fstab
Am 15.12.2011 14:39, schrieb Anton Aylward:
Christoph Bartoschek said the following on 12/15/2011 07:51 AM:
t is quite embarassing but I have found my problem. Starting with 11.4
the nfs service is not starting automatically. One has to enable it for
runlevels 3,5 to get automatically mounted remote filesystems.

I wonder why I thought that this problem started with 12.1. I think the
few 11.4 machines we have were not rebooted after initial setup so the
problem did not appear.

To sum up: for opensuse systemd is not responsible for mounting remote
filesystems. It is the nfs service.

Enabling the service solves the problem. However it does not solve the
hang with comment=systemd.automount. So I had to remove the comment.

I'm sorry, this makes no sense to me.

NFS doesn't mount the file systems.

You mount them in the automounter or the fstab with 11.4 or
with explicit units or the fstab with SystemD

In both pre- and post- SystemD the NFS server is in the kernel.
Go grep.

ps -ef | grep nfs
root 12354 2 0 08:30 ? 00:00:00 [nfsiod]
root 12365 8299 0 08:30 pts/0 00:00:00 grep nfs

I've quoted the lines from the systemd.mount man page.
It clearly states that the systemd functions take care of the mounting.

My complaint here is that there isn't enough logging form systemD
appearing in the system logs that Christoph supplied.

As I've said, I be happy to take this off list with Christoph and do a
detailed gap analysis against a system where this automount works.


Hi,

for me it seems as if in opensuse 12.1 systemd is not directly responsible for mounting NFS filesystems. Instead there is still the /etc/init.d/nfs script that is started after the network has been brought up.

Systemd correctly starts the scripts and I am fine.

Obviously systemd has the feature to manage NFS mounts directly. This is indicated by the comment=systemd.automount option. However using this option alone leads to a hang on my system.

Maybe this is related to the fact that the network cable is attached to eth2 and not eth0. I do not know. I also do not know whether systemd tried to bring up the network before it tried to mount the filesystems. I even do not know whether it tried to mount the filesystems at all.

If you want to dig further into the issue I can run some tests. But you have to give me specific instructions on what you would like to see and how to generate this.

Christoph
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread