Mailinglist Archive: opensuse (1658 mails)

< Previous Next >
Re: [opensuse] perl module install question
Greg Freemyer wrote:
I'm trying to install perl-IO-Compress from OBS, but it says I need perl
5.14.2

The strange thing is I have perl 5.14.2, so I'm confused. If anyone
can tell me what's going on, I'd appreciate it.
[snip]
sudo zypper in perl-IO-Compress
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: perl-IO-Compress-2.036-2.1.noarch requires perl = 5.14.2, but
this requirement cannot be provided
Solution 1: do not install perl-IO-Compress-2.036-2.1.noarch
Solution 2: do not install perl-IO-Compress-2.036-2.1.noarch
Solution 3: break perl-IO-Compress by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c):

As far as I can see, that's an RPM packaging error rather than a perl
packaging error, yes? In which case I can't help, and all I can suggest
is one or all of:
(1) poke around the RPM files and see what is going on
(2) check perl -V returns what you expect and that installing
IO::Compress from CPAN works (you can always delete it later)
(3) if nobody else replies, try reposting to this list with RPM or
zypper in the subject instead of perl

Cheers, Dave
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References