Mailinglist Archive: opensuse (1658 mails)

< Previous Next >
[opensuse] perl module install question
  • From: Greg Freemyer <greg.freemyer@xxxxxxxxx>
  • Date: Tue, 6 Dec 2011 16:17:04 -0500
  • Message-id: <CAGpXXZ+xRVOM4ovjLTtJ2dowNq1aCVVcCtoyZ=zpnxDFoLW0fg@mail.gmail.com>
I'm trying to install perl-IO-Compress from OBS, but it says I need perl 5.14.2

The strange thing is I have perl 5.14.2, so I'm confused. If anyone
can tell me what's going on, I'd appreciate it.

=== zypper output that details the above

zypper se -s perl-base
Loading repository data...
Reading installed packages...

S | Name | Type | Version | Arch | Repository
--+-----------------+---------+------------+--------+------------------
i | perl-base | package | 5.14.2-1.9 | x86_64 | openSUSE-12.1-OSS
v | perl-base | package | 5.14.2-1.9 | i586 | openSUSE-12.1-OSS
| perl-base-32bit | package | 5.14.2-1.9 | x86_64 | openSUSE-12.1-OSS


As you can see I have perl 5.14.2 installed from the openSUSE 12.1 main repo
===================================================================
sudo zypper se -s perl-IO-Compress
root's password:
Loading repository data...
Reading installed packages...

S | Name | Type | Version | Arch | Repository
--+------------------+------------+-----------+--------+---------------------
| perl-IO-Compress | package | 2.036-2.1 | noarch | devel:languages:perl
| perl-IO-Compress | srcpackage | 2.036-2.1 | noarch | devel:languages:perl


And perl-IO-Compress is in the devel:languages:perl repo
===================================================================
zypper lr 3
Alias : devel:languages:perl
Name : devel:languages:perl
URI :
http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_12.1
Enabled : Yes
Priority : 99
Auto-refresh : On
Keep Packages : Off
Type : rpm-md
GPG Check : On
GPG Key URI :
Path Prefix :
Parent Service :
MD Cache Path : /var/cache/zypp/raw/devel:languages:perl


And the perl repo I have loaded is the one for 12.1
===================================================================
sudo zypper in perl-IO-Compress
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: perl-IO-Compress-2.036-2.1.noarch requires perl = 5.14.2, but
this requirement cannot be provided
Solution 1: do not install perl-IO-Compress-2.036-2.1.noarch
Solution 2: do not install perl-IO-Compress-2.036-2.1.noarch
Solution 3: break perl-IO-Compress by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c):


But when I try to install perl-IO-Compress, I claims I don't have the
right version of perl
===================================================================


Thanks
Greg
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >