Mailinglist Archive: opensuse (1677 mails)

< Previous Next >
Re: [opensuse] Driver installation for Xerox Phaser 3117 printer
On Thursday 01 December 2011 17:42:45 Haro de Grauw wrote:
On 01/12/11 16:09, Bogdan Cristea wrote:
Does anyone has managed to install the drivers for Xerox Phaser 3117
printer ? Yast detects my printer but there are no drivers provided.

thanks

Hi Cristea,

Find the printer on the Xerox website, then follow the links for driver
download, select "linux" as your OS, which should take you here:

http://www.support.xerox.com/support/phaser-3117/file-download/enin.html?op
eratingSystem=linux&fileLanguage=en_GB&contentId=54207&from=downloads&viewA
rchived=false

This gets you a 26MB driver package. Most of this is software that you
neither need nor want; the bit you need is the PPD file.
(see here: http://en.wikipedia.org/wiki/PostScript_Printer_Description)

So you save the package, open it with Ark, go to the "ppd" folder, then
"C", then extract the file Phaser-3117.ppd, and save this somewhere on
your system. Then, you can delete the (rest of the) package.

Finally go to YaST > Printer > Add > Driver packages ... and simply
point it at the PPD file you extracted.

Hope this helps,
Haro

Hi

It does not work, I get the following errors:

/home/bogdan/Soft/xerox/ppd/C/Phaser-3117.ppd: FAIL
**FAIL** REQUIRED DefaultImageableArea
REF: Page 102, section 5.15.
**FAIL** REQUIRED PageRegion
REF: Page 100, section 5.14.
**FAIL** BAD Product - not "(string)".
REF: Page 62, section 5.3.
**FAIL** Bad Resolution choice 600!
REF: Page 84, section 5.9
**FAIL** Bad Resolution choice 300!
REF: Page 84, section 5.9
**FAIL** Missing cupsFilter file "/usr/lib/cups/filter/ppmtospl2"
**FAIL** Missing REQUIRED PageRegion option!
REF: Page 100, section 5.14.
**FAIL** Size "Letter" defined for PageSize but not for PageRegion!
**FAIL** Size "Legal" defined for PageSize but not for PageRegion!
**FAIL** Size "A4" defined for PageSize but not for PageRegion!
**FAIL** Size "Executive" defined for PageSize but not for PageRegion!
**FAIL** Size "Folio" defined for PageSize but not for PageRegion!
**FAIL** Size "JB5" defined for PageSize but not for PageRegion!
**FAIL** Size "B5" defined for PageSize but not for PageRegion!
**FAIL** Size "A5" defined for PageSize but not for PageRegion!
**FAIL** Size "COM10" defined for PageSize but not for PageRegion!
**FAIL** Size "Monarch" defined for PageSize but not for PageRegion!
**FAIL** Size "DL" defined for PageSize but not for PageRegion!
**FAIL** Size "C5" defined for PageSize but not for PageRegion!
**FAIL** Size "C6" defined for PageSize but not for PageRegion!
**FAIL** Size "A6" defined for PageSize but not for PageRegion!
WARN DefaultLinuxGDIBand has no corresponding options!
WARN PCFileName longer than 8.3 in violation of PPD spec.
REF: Pages 61-62, section 5.3.

REF is the Adobe PostScript Printer Description File Format Specification

Also, I have already used this solution by moving directly the archive
containing the ppd file for my printer to the folder where the other ppd files
were, but still no luck.

regards
--
Bogdan
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >