Mailinglist Archive: opensuse (1786 mails)

< Previous Next >
Re: [opensuse] nVidia on 12.1 / Cannot start X [still not working]
Quoting Adam Tauno Williams <awilliam@xxxxxxxxxxxxx>:
Quoting Roger Luedecke <roger.luedecke@xxxxxxxxx>:
Third party repos should be removed/disabled for a system upgrade because we
cannot and should not support them.
In the scenario of a zypper dup, no. ALL old repositories should be removed or disabled.
I did not use zypper dup.
I (a) disabled all third party repositories (b) booted from an instal DVD (c) performed the upgrade.
I have now installed just the G02 package, removed /etc/X11/xorg.conf, reran nvidia-xconfig, and startx still fails with "This server hsa an unsupported input driver ABI version (have 12.2 need < 12.0)." It then dies with a seg fault / sig-11 in ""
01:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 230M] (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)

Rebooting (since this appears to rely on kernel modules) doesn't change anything [I'd like to try a "zypper up" but since zypper is currently broken as well I can't].

In dmesg, at boot I see -

NVRM: loading NVIDIA UNIX x86_64 Kernel Module 285.05.09 Fri Sep 23 17:31:57 PDT 2011

How can I just fall back to the nouveau driver? I tried removing all the nvidia related packages, reinstalling the xorg-x11-driver-video-nouveau package from the DVD, removing /etc/X11/xorg.conf, but X still fails to start.

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >