Mailinglist Archive: opensuse (1786 mails)

< Previous Next >
[opensuse] nVidia on 12.1 / Cannot start X
I upgraded by GNOME 3.0 openSUSE 11.4 box to 12.1. That seemed to go OK. But after logging in I go to GNOME fallback rather than Shell [where Shell worked perfectly under 11.4]. Not only was it fallback - but a hideous nearly Black-n-White fallback. Anyway I figured this was because I needed to reenable and reinstall the nVidia repos. I did that - and now X is broken. Uninstalling the X nvidia packages and I can't even get back to fall back. Is there a way to 'reset' X? isax fails with the inability to load a perl module. I've tried removing/reinstalling nvidia, rebooting, etc... as well as mucking around with xorg.conf. I'd be happy to even have hideous fallback mode back.

Failure with nVidia drivers installed - X-Fail-1.txt
Failure now after removing packages - X-Fail-2.txt

01:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 230M] (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)

xorg-x11-7.6-67.1.4.x86_64
Linux linux-yu4c.site 3.1.0-1.2-desktop #1 SMP PREEMPT Thu Nov 3 14:45:45 UTC 2011 (187dde0) x86_64 x86_64 x86_64 GNU/Linux
xauth: file /root/.serverauth.2303 does not exist


X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux-yu4c.site 3.1.0-1.2-desktop #1 SMP
PREEMPT Thu Nov 3 14:45:45 UTC 2011 (187dde0) x86_64
Kernel command line: root=/dev/Beast/Root
resume=/dev/disk/by-id/ata-ST9500420AS_5VJ1A77Z-part1 splash=silent quiet
nomodeset vga=0x314
Build Date: 10 November 2011 03:34:36PM

Current version of pixman: 0.22.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Nov 19 09:05:44 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Error: API mismatch: the NVIDIA kernel module has version 173.14.30,
but this NVIDIA driver component has version 285.05.09. Please make
sure that the kernel module and all NVIDIA driver components
have the same version.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the
(EE) NVIDIA(0): system's kernel log for additional error messages and
(EE) NVIDIA(0): consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional
information.

xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
-------------------------------------------------------------------------------------------
xinit failed. /usr/bin/Xorg is not setuid, maybe that's the reason?
If so either use a display manager (strongly recommended) or adjust
/etc/permissions.local
xauth: file /root/.serverauth.2506 does not exist


X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux-yu4c.site 3.1.0-1.2-desktop #1 SMP
PREEMPT Thu Nov 3 14:45:45 UTC 2011 (187dde0) x86_64
Kernel command line: root=/dev/Beast/Root
resume=/dev/disk/by-id/ata-ST9500420AS_5VJ1A77Z-part1 splash=silent quiet
nomodeset vga=0x314
Build Date: 10 November 2011 03:34:36PM

Current version of pixman: 0.22.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Nov 19 09:22:40 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Failed to load /usr/lib64/xorg/modules/updates/extensions/libglx.so:
/usr/lib64/xorg/modules/updates/extensions/libglx.so: cannot open shared object
file: No such file or directory
(EE) LoadModule: Module glx does not have a glxModuleData data object.
(EE) Failed to load module "glx" (invalid module, 0)
(EE) [drm] failed to open device
(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional
information.

xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
-------------------------------------------------------------------------------------------
xinit failed. /usr/bin/Xorg is not setuid, maybe that's the reason?
If so either use a display manager (strongly recommended) or adjust
/etc/permissions.local
< Previous Next >
Follow Ups