Mailinglist Archive: opensuse (1690 mails)

< Previous Next >
[opensuse] webcam video dark, maybe wrong driver?
Hello,

I have an A4Tech PK-720G webcam plugged into my USB port. It has a built in microphone. I managed to get skype to pick up the camera microphone input (using pulse audio manager), and the video works to some degree, but it shows a very dark image even when I am in a very well-lighted room.

Skype says it is using A4TECH USB2.0 PC CAMERA J(/dev/video0)

If I run lsusb, the third line shows the following:

Bus 001 Device 002: ID 0ac8:c40a Z-Star Microelectronics Corp.

Also, the lines related to video when I run lsmod show the following:

uvcvideo 70281 0
videodev 81448 1 uvcvideo
v4l1_compat 17505 2 uvcvideo,videodev
v4l2_compat_ioctl32 10573 1 videodev

I don't really know what those indications mean, and I am kind of at a loss as to what to do next. I google searched for a driver that linux can use with this camera and couldn't find anything.

How do I find a correct driver for this camera and what do I need to tweak to make it work right?

Thanks
George

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups