Mailinglist Archive: opensuse (818 mails)

< Previous Next >
Re: [opensuse] Virtual box running out of disk space
On Fri, Sep 16, 2011 at 2:08 PM, Fr David Ousley
<davidousley@xxxxxxxxxxx> wrote:
On Fri, 16 Sep 2011 14:16:32 -0400, David C. Rankin
<drankinatty@xxxxxxxxxxxxxxxxxx> wrote:

On 09/16/2011 06:38 AM, Fr David Ousley wrote:

In the Virtual Box Settings > Storage, it shows the correct file, with
the
correct size 20 gigs.  In Windows, Computer > Hard disk properties shows
the old
size, 10 gigs.

I also noted that VBoxManage has an expand utility, which I had tried
earlier,
before posting.  I tried that on the old file and successfully expanded
it to 15
gigs.  But in widows it still shows 10.  So it seems to be a windows
issue, and
I don't see an obvious way around it.  It seems like it must be something
obvious, which I didn't see.

It went very smooth on this end...

It was very smooth here too, until the last step .../

Thanks for your efforts!

Hmmm...

  Obviously something isn't right. Let's start with a .vdi file review on
your system. Under ~/.VirtualBox, the .vdi location has changed not too long
ago. Originally, I had my .vdi files under ~/.VirtualBox/VDI:


Mine are set up in the second way: the .vdi files under each machine's
directory.  The Virtual Box set up does not complain, however, about using a
hard disk from another directory.

  Is there anyway possible you are still actually booting your old .vdi
due to the changed path to the new .vdi file??

I think we can eliminate this possibility.  (a) the Virtual Box manager
storage for the machine (shown before booting) lists the correct .vdi (in my
case xp2.vdi rather than windowsxp.vdi).
(b) I moved windowsxp.vdi completely out of the Virtual Box tree (too
paranoid to delete it entirely).
(c) windowsxp.vdi has been expanded to 15 gigs using VBoxManage modifyhd
--expand, so there should still be room if that were the one being used.

And Windows when booted shows a 10 gig hd, completely full.

The detailed instructions to which you referred me mentioned using Disk
Management in Windows 7 to recognize the added space, though it says nothing
about XP, and I can find no equivalent.  This led me to suspect windows
rather than Virtual Box, as the latter seems to be correctly configured.

The only thing left to try that I can think of is creating a new, fixed size
disk.  But we do seem close on this one, should you have another idea.

I seem to recall that this issue is a shortcoming in Windows. After
using VBoxManage to re-size a .vdi image, it's necessary to make
Windows aware of the re-sized disk. This can be done using a tool
called Easus Partition Manager. A free version is available here:
http://www.partition-tool.com

--
JAY VOLLMER
I write technical manuals, therefore, I am a manual laborer
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups