Mailinglist Archive: opensuse (882 mails)

< Previous Next >
Re: [opensuse] 11.4 Xproblem
  • From: Felix Miata <mrmazda@xxxxxxxxxxxxx>
  • Date: Thu, 16 Dec 2010 22:20:27 -0500
  • Message-id: <4D0AD6FB.1010103@xxxxxxxxxxxxx>
On 2010/12/16 17:44 (GMT-0500) Bob S composed:

I am playing with 11.4. I have this X problem I can't figure out.

First of all it boots to the command line. Then I can get my graphics with
root only with a startx. The two users cannot and get the following message.

-----------------------------------------------------------------------------------------
xauth: file /home/bob/.serverauth1234 does not exist

Fatal server error:
cannot move old log file "/var/log/Xporg.0.log" to "var/log/Xorg.0.log.old"

xinit server error
-----------------------------------------------------------------------------------------
and drops me back to the prompt. Then I get some info that says:

"xinit failed. /usr/bin/Xorg is not set uid" (could this be the problem?)
"if so either use a display manager or adjust /etc/permissions.local"

Which I don't know how to do. I have checked the Xorg wiki and googled
the problem. Nothing on the wiki. Google produced one exact hit from 2008
but I couldn't duplicate their solution. Hope somone can help.

At the time I did your 11.4 install, X had been announced to be non-functional in Factory. Whatever was broken then may never have been installed in full, and thus not upgraded when you dup'd. If you would boot 11.3 and run 'rpm -qa | grep x11 > outfile.txt', you could do the same thing on a 11.4 boot and compare the two outputs. If something's missing from the 11.4 list, install it with zypper in.
--
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409

Felix Miata *** http://fm.no-ip.com/
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References