Mailinglist Archive: opensuse (1839 mails)

< Previous Next >
Re: [opensuse] Frequent hangs in 11.3 + 4.5 continue
  • From: Bob Williams <linux@xxxxxxxxxxxxxxxxxxxxx>
  • Date: Thu, 30 Sep 2010 16:44:44 +0100
  • Message-id: <201009301644.45027.linux@xxxxxxxxxxxxxxxxxxxxx>
On Wednesday 29 Sep 2010 21:43:57 Will Stephenson wrote:
On Wednesday 29 September 2010 21:11:11 Bob Williams wrote:
There was some discussion in the past few weeks about frequent freezes of
the mouse and keyboard. See thread "This guy _really_ likes kde 4.5". I
have tried various changes of kernel, and am now back on 2.6.34.7-0.3. I
have also upgraded dbus to 1.4, but the problems continue unchanged.

If anyone else who experienced the same problems found a solution, I
would be grateful for a pointer.

The mouse and keyboard hangs aren't dbus related - the dbus threading issue
just makes the app itself freeze.

I would see if you can reproduce the hangs with a new user account. If
you can't, start adding apps that you usually use in your normal user
account until the behaviour manifests. If it does appear with the new
user, I tend to suspect an unlucky constellation of kernel and nvidia
driver. Try a different nvidia driver if possible.

FWIW in the earlier thread I noticed that you use Yakuake. This does use
the 3D hardware to do its translucency effect.

Thanks, Will. I tried starting all my usual apps in a new user account, but
couldn't get the undesired behaviour to repeat itself. This includes yakuake,
gkrellm, basket notes, amarok, kontact and firefox.

I had thought I was suffering from bug #638200, but this is marked as fixed.

I'm inclined to agree (with my limited knowledge) that it's a graphics driver
problem. Is there a quick and dirty how-to which would guide me through
switching from the nvidia proprietary drivers to the nouveau driver?
Uninstalling the nvidia driver in YaST left me with no graphics at all. The
nouveau driver appears to be installed, I just have to get it to function.

Or maybe it's the nouveau driver that's causing the problem? I've read the
wiki entry on nvidia graphics problems, but I'm hesitant to edit xorg.conf if
that's not the cause.

TIA,

Bob



--
Registered Linux User #463880 FSFE Member #1300
GPG-FP: A6C1 457C 6DBA B13E 5524 F703 D12A FB79 926B 994E
openSUSE 11.3 64-bit, Kernel 2.6.34.7-0.3-desktop, KDE 4.5.1
Intel Core2 Quad Q9400 2.66GHz, 8GB DDR RAM, nVidia GeForce 9600GT
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >