Mailinglist Archive: opensuse (1839 mails)

< Previous Next >
Re: [opensuse] latest kernel update breaks ATI binary driver
  • From: jsa <jsamyth@xxxxxxxxx>
  • Date: Thu, 23 Sep 2010 15:24:23 -0700
  • Message-id: <4C9BD397.5010107@xxxxxxxxx>
On 09/23/2010 03:08 PM, Marcus Meissner wrote:
On Thu, Sep 23, 2010 at 03:06:52PM -0700, John Andersen wrote:
On 9/23/2010 2:55 PM, Anders Johansson wrote:
On Thursday 23 September 2010, Vadym Krevs wrote:
IMHO, this could have been handled differently. E.g., the updated kernel
could have been released once an updated ATI driver was available.

As to a patch - well, it is easy to find and apply, if you're a software
engineer like myself. What about the average Joe user ... So much for
the strategy statement: "The target users of the openSUSE distribution
are people who need to get work done and want something *stable* and
usable for their every day needs."

"Joe user" would use the pre-built packages. From what I understand, they
will
continue working without needing a recompile, since the affected function
was
an inline function before, so the code is already inside the driver. As far
as
I know it will continue working without needing any change (but I don't
currently have any ATI cards, so I can't back this up from personal
experience, it is just what I have heard reported).

Anders

The prebuilt ATI packages wont install either Anders.

Really? WHat is the error?

That leaves you with their Driver Loader packages.
The driver loader package ATI distributes builds drivers on the fly
and it fails too. If I roll back one kernel, it will (maybe) build.

Joe user would be stuck using the open source drivers and forgo
compositing and run it as a 2D card. (Grousing all the while).

We figured and tested that the existing driver would still work, but
apparently
this did not apply to all cases.

AMD/ATI also has a patch for the issue to their driver.

Ciao, Marcus

I can't speak to all cards, but in my case their driver does not exist
for my Mobility Radeon x1400 card any more and I had to use their
package to built RPMs and then install those for the last several
versions of opensuse.

See this ARchives thread of yesterday:
http://linux.derkeiler.com/Mailing-Lists/SuSE/2010-09/msg01430.html

I can't go to AMD and download anything.
masterpatricko site, quoted in above archive message works for 2.6.33
but not 34.

The ATI repository has nothing for my card.
See http://en.opensuse.org/SDB:ATI_drivers



--
Explain again the part about rm -rf /
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >