Mailinglist Archive: opensuse (1839 mails)

< Previous Next >
Re: 2 shockwave flash plugins 9.0 & 10.2 - howto fix ( was Re: [opensuse] Adobe Releases 64-bit Linux Flashplugin at AdobeLabs)
  • From: Wolfgang Rosenauer <wolfgang@xxxxxxxxxxxxx>
  • Date: Fri, 17 Sep 2010 07:39:28 +0200
  • Message-id: <4C92FF10.3040900@xxxxxxxxxxxxx>
David,

Am 17.09.2010 00:40, schrieb David C. Rankin:
Where does this thing hide and how can I remove it?


Son-of-a-gun, I fixed it by trial and error. I moved all the
libtotem and libswdec files to a dir, then copied new libtotem files
from an 11.3 box and softlinked libflashplyer.so and flash started
working just like it should. Here is what ended up in
/usr/lib64/browser-plugins:

swfdec is an alternative implementation of Flash (which is not really
stable or up to date afaik).
You can have both installed basically but then you need to define the
correct one using Tools->Manage content plugins because Firefox uses a
random order to find a suitable plugin.
(So for all the people thinking that upstream Firefox is the only real
Firefox or wondering where that option is on their installations should
know that this is broken upstream and only possible in the openSUSE
branded Firefox (and Ubuntu's AFAIK).)

Wolfgang
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >