Mailinglist Archive: opensuse (1839 mails)

< Previous Next >
Re: [opensuse] This guy _really_ likes kde 4.5
  • From: Bob Williams <linux@xxxxxxxxxxxxxxxxxxxxx>
  • Date: Thu, 16 Sep 2010 15:38:31 +0100
  • Message-id: <201009161538.31179.linux@xxxxxxxxxxxxxxxxxxxxx>
On Thursday 16 Sep 2010 14:43:19 Randall R Schulz wrote:
On Thursday September 16 2010, Bob Williams wrote:
On Thursday 16 Sep 2010 04:57:15 Rajko M. wrote:
...

Would this also explain why my mouse pointer gets stuck every 30 secs
or so? My keyboard buffer is also sluggish, and intermittently loses
characters. IOW I'm typing away (I'm not a fast typer, so I'm not
filling up the buffer quickly) when the screen stops displaying the
characters I've typed. After a few seconds, it catches up, but may
have forgotten some of the characters, so I have to keep going back
and correcting my work. This can be especially frustrating when it
happens while I'm entering a masked password on a website, for
example.

Does everything with a connection to the screen pause? In my experience,
things that you can tell are running but don't interact with the screen
continue (audio plays, e.g.) but everything else pauses. Even mouse
tracking freezes during these pauses.

I run GKrellM and a CPU spike that is bout 70% kernel mode is recorded
for the duration of these pauses, though it appears there only after
the pause is over, since as I said, all graphics updating pauses.

I have this symptom usually only when 3D apps are running, but it can
occur at other times. Some digging on the Web turned up a kernel
command line (boot-time) parameter that virtually eliminated the
symptom outside of 3D apps:

vmalloc=192M


However, it's still too common when running 3D apps, and I find it
_extremely_ annoying and disruptive and would dearly love to figure out
what's going on and how to fix it. It is definitely not periodic and
the pauses are of varying durations, from less than a second to a few
seconds.

I'm currently running gkrellm, Amarok, Firefox, Kontact, Krusader, two
instances of OpenOffice and mc in a terminal. Yakuake is running, but hidden,
and I've got KeepassX, Basketnotes and skype in the system tray. I don't think
any of those are 3D apps?

This symptom appeared for me as soon as I replaced the open-source
nVidia driver with the proprietary one and was unaffected by the KDE
4.5.1 upgrade.

Your description seems to fit. I also run gkrellm, and notice the spikes.

I shall try the boot parameter you suggest above.

My system details are in my sig, below.

Bob
...
openSUSE 11.3, Kernel 2.6.34.12-desktop, KDE 4.5.1
Intel Core2 Quad Q9400 2.66GHz, 8GB DDR RAM, nVidia GeForce 9600GT

My configuration is similar. Dual core, not quad, 4 GB not 8, nVidia
8600GT, not 9600GT.

You don't say whether you're running 32-bit or 64. I'm running 32-bit.

64-bit

Randall Schulz

--
Registered Linux User #463880 FSFE Member #1300
GPG-FP: A6C1 457C 6DBA B13E 5524 F703 D12A FB79 926B 994E
openSUSE 11.3, Kernel 2.6.34.12-desktop, KDE 4.4.4
Intel Core2 Quad Q9400 2.66GHz, 8GB DDR RAM, nVidia GeForce 9600GT
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups