Mailinglist Archive: opensuse (1517 mails)

< Previous Next >
Re: [opensuse] serial ports not working
  • From: Paul Neuwirth <mail@xxxxxxxxxxxxxxxx>
  • Date: Sun, 5 Sep 2010 15:52:12 +0200
  • Message-id: <20100905155212.138c753f@xxxxxxxxxxxx>
On Sat, 04 Sep 2010 15:35:52 +0200
"Carlos E. R." <robin.listas@xxxxxxxxx> wrote:

On 2010-09-03 15:50, Paul Neuwirth wrote:
Hello list,
some of my serial ports are not working. ttyS0 mainboard's port
doesn't work, ttyS[45] (PCI-express card) don't work, only ttyS[67]
(PCI card) work correctly. I tried the different ports with my
modems, a video terminal and my UPS, they work on ttyS[67] but not
with the others - using the same configuration and permissions.
Probing the modems (using hylafax's probemodem) makes the modem's
leds blink, but will fail, on my VT i get hieroglyphics instead of
a login.

It smells to me of bad speed settings, or bad cable (inside or
outside the box).

Double check that the speed, parity, stop bits are the same on all
ports. If not that, then try to change the internal cables.

tried again my vt on all serial ports with 9600bauds 8N1.
only ttyS[67] work, onboard - nothing happened, ttyS[45] hieroglyphics.
The failing of the onboard serial port could be caused by bad cabling.
There was an internal connector, bought an extra slot module, maybe
it's not compatible.
The non-working pci-express addon card(exsys ex-44390) doesn't have any
internal cables, only an octopus cable.

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >