Mailinglist Archive: opensuse (1815 mails)

< Previous Next >
Re: [opensuse] Mobile broadband
  • From: C <smaug42@xxxxxxxxx>
  • Date: Mon, 5 Jul 2010 09:41:08 +0200
  • Message-id: <AANLkTin4Vp8IVssSvDa1vjKDX3qFcx7M6oFeCx7qLBro@xxxxxxxxxxxxxx>
On Mon, Jul 5, 2010 at 09:17, Roger Oberholtzer wrote:
I have been trying to get mobile broadband working on my laptop. I tried
openSUSE11.2, and now 11.3. I have a certain amount of success. But no
final joy. I suspect it is my lack of knowledge that is the problem
here.

I am trying to use a Swedish service called "Comviq Surf" that provides
a USB modem. It is a per-day/week/month service, similar to what you get
in hotels for wireless. The modem is (from lsusb):

 idVendor           0x12d1 Huawei Technologies Co., Ltd.
 idProduct          0x1001 E620 USB Modem
 bcdDevice            0.00
 iManufacturer           2 HUAWEI Technology
 iProduct                1 HUAWEI Mobile

[snip]

This looks a lot like what I get with the Vodafone UMTS stick I use in
Germany. I fiddled with the same steps you did, with the same
results.

The first issue is the USB Mode switch... with 11.2, anything provided
via the repos (version 0.9.6) didn't really work.. it appeared to turn
off the USB drive part, but never properly initialized the modem. i
haven't tried again with 11.3 - but I think that comes with 1.1.2....
with Ubuntu 10.04, the USB mode switch (version 1.1.0-2) works fine.
So I'm guessing that's the first step... make sure you're using a high
enough version of the USB Modeswitch app.

I've not been able to convince Gnome or KDE4 NetworkManagers to
connect (in openSUSE 11.2 updated to Factory, openSUSE 11.3 RC2, and
Ubuntu 10.04).

Two critical bits of info you already have found... The APN and the
number to dial... I tried the same info, but for Vodafone Germany in
my NetworkManager... same identical results as you reported...

My solution was this: https://forge.betavine.net/frs/?group_id=12
This is specific to Vodafone, but... maybe there is some why you can
adapt it to your provider? It appears to be the same class of device
(internally a Huawei... I'm not 100% sure on the device/product
number)....

C.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References