Mailinglist Archive: opensuse (1815 mails)

< Previous Next >
[opensuse] Mobile broadband
  • From: Roger Oberholtzer <roger@xxxxxx>
  • Date: Mon, 05 Jul 2010 09:17:39 +0200
  • Message-id: <1278314259.5709.37.camel@xxxxxxxxxxxx>
I have been trying to get mobile broadband working on my laptop. I tried
openSUSE11.2, and now 11.3. I have a certain amount of success. But no
final joy. I suspect it is my lack of knowledge that is the problem
here.

I am trying to use a Swedish service called "Comviq Surf" that provides
a USB modem. It is a per-day/week/month service, similar to what you get
in hotels for wireless. The modem is (from lsusb):

idVendor 0x12d1 Huawei Technologies Co., Ltd.
idProduct 0x1001 E620 USB Modem
bcdDevice 0.00
iManufacturer 2 HUAWEI Technology
iProduct 1 HUAWEI Mobile

There are some issues with this device presenting itself as a disk.
Happily, openSUSE contains the support to deal with this (unmount the
disk and then access the GSM modem part). After the devices is attached,
I see this in /var/log/messages:

NetworkManager: <info> (ttyUSB0): new GSM device (driver: 'option1')
NetworkManager: <info> (ttyUSB0): exported as
/org/freedesktop/NetworkManager/Devices/2
NetworkManager: <info> (ttyUSB0): now managed
NetworkManager: <info> (ttyUSB0): device state change: 1 -> 2 (reason 2)
NetworkManager: <info> (ttyUSB0): deactivating device (reason: 2).
NetworkManager: <info> (ttyUSB0): device state change: 2 -> 3 (reason 0)
NetworkManager: <WARN> user_connection_get_settings_cb():
user_connection_get_settings_cb: Invalid connection: 'NMSettingGsm' / 'number'
invalid: 2
NetworkManager: <WARN> wait_for_connection_expired(): Connection (2)
/org/freedesktop/NetworkManagerSettings/1 failed to activate (timeout): (0)
Connection was not provided by any settings service
NetworkManager: <WARN> wait_for_connection_expired(): Connection (2)
/org/freedesktop/NetworkManagerSettings/1 failed to activate (timeout): (0)
Connection was not provided by any settings service

Which looks like a mix of good and bad news. Given that I do not know
what 'reason 2' or 'reason 0' are, well, who is to say which type of
news this is. I do have this device:

crw-rw---- 1 root dialout 188, 0 2010-07-04 21:41 /dev/ttyUSB0

Anyway, at this point, the KDE Network Manager has detected it, and
allows me to configure it. Of course, this is where the fun starts.

I found a site that provides some information about this device under
Linux (it is all in Swedish):

http://linuxwiki.se/index.php/Mobilt_bredband

So, I tried their suggested configuration, which is mainly that the APN
is either data.comviq.se or mobileinternet.tele2.se, and that the number
is #99*. So, I entered this information in the Network Manager. I also
entered the PIN and PUK code. The manager accepts and remembers the
settings.

And that is where I find myself. I do not see a connection happening.
There is an occasional blue light (heartbeat-looking) on the USB modem.
But nothing more.

I tried disabling my wireless connection so that, in the absence of any
connection, this one might be initiated. Nope.

Having gotten this far, I cannot believe that the final steps are
broken. (I see half-full glasses everywhere.) I just do not know what
the next step is supposed to be. I expected the modem to make a
connection that allows my browser visit a page to enter the pay card
number and thus start the clock ticking on a 24-hour session. Like in a
hotel wireless setup. I have the code. Just no place to use it!

My suspicion is that the next step involves ppp. Since I entered the
number to call, I would think Network Manager is planning on making the
call and initiating the connection. Perhaps not. Maybe it is just
nosy/misleading and expects me to do more configuration elsewhere?

Any suggestions?


--
Roger Oberholtzer

OPQ Systems / Ramböll RST

Ramböll Sverige AB
Krukmakargatan 21
P.O. Box 17009
SE-104 62 Stockholm, Sweden

Office: Int +46 10-615 60 20
Mobile: Int +46 70-815 1696

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >