Mailinglist Archive: opensuse (1815 mails)

< Previous Next >
[opensuse] sharing printer to OS X - can't get to work
  • From: HG <hg.list@xxxxxxxxx>
  • Date: Sun, 4 Jul 2010 17:23:23 +0300
  • Message-id: <AANLkTin94cEg2wge1_FFyCPPGyVmZcvT2PNQ_tJQ8p7m@xxxxxxxxxxxxxx>

11.3 is just about to come out! Excellent! However, I'm still on 11.2
and I'm pretty much stuck on trying to share printer to OS X 10.6.4. I
really hope somebody can help here, even though I know that the
problem can also be on OS X side.

So, I'm running 11.2 and I have Canon iP4300 connected to the server
via USB. I have enabled samba server (from YaST) to share folders.
Works... although form time to time it seems that OS X looses the
connections and can't get them up before reboot (I changed to OS X
from Windows - this isn't making me happy BTW). OpenSUSE server
doesn't have firewall enabled (so that at least that is not the
problem). I've tried everything, but I'll try to recap now...

So, on samba (YaST), I have both printers and print$ enabled. From
CUPS, I have published the printer with name canonip4300. The state is
"idle, accepting jobs, published". I don't even know if I should be
using both Samba and CUPS... however, currently my old WinXP can use
the server to print. So, now from the OS X, I can not seem to be able
to print to this. I am able to add it to the printers from the OS X
GUI as well as OS X CUPS. I've tried to set it with GUI methods as
well as manually with these:
ipp also with the account...
None of those seem to work. The user name and password disappears from
Apple GUI and when I try to print something, I just get: "Tree connect

In the beginning I was not able to print from the old WinXP either
because of authentication errors. Those I was able to solve by
manually listing the linux user names to the openSUSE CUPS printer
share as allowed users. I think that at this point, I also got similar
authentication error on OS X, but I'm not getting those anymore. I
really cannot understand where the problem is. I thought that with
CUPS on both openSUSE on OS X, there should be no problems... :-( So,
huge thanks to anybody who can point me to right direction!

Here is my samba.conf:
# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2010-04-13
workgroup = [name removed, but as curiosity, it does contain "Ä" in it]
passdb backend = tdbsam
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
usershare allow guests = No
security = user
add machine script = /usr/sbin/useradd -c Machine -d
/var/lib/nobody -s /bin/false %m$
domain logons = No
domain master = No
wins support = Yes
netbios name = Box
ldap suffix =
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

## Share disabled by YaST
# [netlogon]

inherit acls = Yes
path = /share
read only = No

And here is the printers part from CUPS
# Printer configuration file for CUPS v1.3.11
# Written by cupsd on 2010-07-04 15:03
<DefaultPrinter canonip4300>
Info Canon iP4300 with driver Canon PIXMA iP4300 - CUPS+Gutenprint v5.0.2
DeviceURI usb://Canon/iP4300
State Idle
StateTime 1278244930
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
AllowUser myusername
AllowUser otherusername
OpPolicy default
ErrorPolicy stop-printer


To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups