Mailinglist Archive: opensuse (1714 mails)

< Previous Next >
Re: [opensuse] Re: 1/2 of libqt4-x11 packages failing to install in 11.0 update from kde4 factory
  • From: Marcus Meissner <meissner@xxxxxxx>
  • Date: Sat, 3 Jul 2010 00:08:24 +0200
  • Message-id: <20100702220824.GE18436@xxxxxxx>
On Fri, Jul 02, 2010 at 11:56:27AM -0500, David C. Rankin wrote:
On 07/02/2010 11:19 AM, Ken Schneider - openSUSE wrote:


You may want to check to make sure that any repos you have defined afe
still valid. The path to them may have been moved to a discontinued path
with the demise of 11.0.


Thanks Ken, I did, it's just a couple of broken packages that a developer
dumped into the 11.0 kde4 factory desktop repo and cppdev repo. For the
record, the broken packages introduced into the 11.0 repos were:

libqt4-x11-32bit-4.6.3-120.2.x86_64.rpm
libqt4-x11-4.6.3-120.2.x86_64.rpm
binutils-devel-2.20.0-34.1.x86_64.rpm
libqt4-devel-doc-data-4.6.3-122.2.x86_64.rpm
lyx-1.90alpha4-1.4.x86_64.rpm

They all fail with cpio errors:

11:25 alchemy:~/tmp # rpm -Uvh libqt4-x11-4.6.3-120.2.x86_64.rpm
error: failed to stat /home/david/.gvfs: Permission denied
Preparing... ###########################################
[100%]
1:libqt4-x11 ###########################################
[100%]
error: unpacking of archive failed on file
/usr/lib64/libQtDesignerComponents.so.4.6.3;4c2e132e: cpio: read failed -
Bad file descriptor

Reading suggest that is sometimes due to building on a box with corrupted
memory. Hopefully someone will correct the mishap so the latest versions of
the packages are not left corrupted.

libqt4 on openSUSE 11.0 is version 4.4.0.

So please send E-Mail the maintainers of the KDE repo.

Ciao, Marcus
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >