Mailinglist Archive: opensuse (1714 mails)

< Previous Next >
Re: [opensuse] 11.0 - Firefox 3.6.6 will not start
  • From: Wolfgang Rosenauer <wolfgang@xxxxxxxxxxxxx>
  • Date: Thu, 01 Jul 2010 17:28:29 +0200
  • Message-id: <4C2CB41D.4090706@xxxxxxxxxxxxx>
Am 01.07.2010 17:21, schrieb Marcus Meissner:
On Thu, Jul 01, 2010 at 11:19:40AM -0400, Felix Miata wrote:
On 2010/07/01 16:49 (GMT+0200) Wolfgang Rosenauer composed:

Am 01.07.2010 16:14, schrieb Felix Miata:

3.6.4 ran fine. I closed it, then 'zypper in MozillaFirefox', which
installed
xulrunner-1.9.2.6-3.1 and MozillaFirefox-3.6.6-1.1, and now instead of a
working Firefox I get "Couldn't load XPCOM". :-(

Other than running Mozilla's 3.6.6 build, which I'm doing ATM, does this
have
a solution?

Check which version your mozilla-js192 is and update it explicitely if
it's wrong.

I have 1.9.2.4-9.1, but how do I tell if it's wrong?

It should have also -3.1 as Release I guess.

rpm -qi mozilla-js192 will show that is from Packman, not from OBS.

(I wonder why they are incompatibole btw.)

They are probably not _incompatible_. But the old one is installed in
the wrong location (what makes sense). I optimized the RPM requirements
a bit in Factory already. mozilla-js192 is a subpackage only to be able
to install it separately and not to diverge versions between that and
xulrunner.
So if you have FF 3.6.6 you need mozilla-js192-1.9.2.6* (the rpm release
number doesn't really matter).


Wolfgang
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >