Mailinglist Archive: opensuse (933 mails)

< Previous Next >
Re: [opensuse] unable to login to KDE under newly installed 11.2
  • From: Julien Michielsen <julien@xxxxxxxxxxxxxxxxxx>
  • Date: Thu, 3 Jun 2010 17:19:34 +0200
  • Message-id: <201006031719.34591.julien@xxxxxxxxxxxxxxxxxx>
On Thursday 03 June 2010 13:28:12 phanisvara das wrote:
On Thursday, June 03, 2010 03:16:31 pm Lubos Lunak wrote:
On Wednesday 02 of June 2010, Julien Michielsen wrote:
Yesterday I installed 11.2 on my machine, and I don't succeed to
login to my useraccount under X. It prompts for the user, and when
I enter the name, and subsequently the password, the system goes
away for 1 or two seconds after hitting enter, and then comes back
with the login screen. When I enter the name again, and thereafter
password, the same happens again. No error- message, just comes
back like if nothing happened. No error with the password: if I
enter a different password, it gives a "wrong password"-message.
On a console (under eg. alt-ctl-F2)I can login without a problem.
But not under KDE.
Can't find a message in /var/log/messages, the only log I can
imagine as a place for error-messages.
Or does a different log give better indications?

to me the same thing happened when, after some upgrades, desktop effects
weren't working anymore. the user account that had effects enabled would
react just like that, i.e., revert to the KDE login after a couple
seconds.

at that time i fixed it by manually editing kwinrc in
~/.kde4/share/config, setting "enabled" to false under the [Compositing]
heading.

--
phani.

Thank you for your promising hint, which I tried immediately.
However, my kwinrc did not show many parameters, hardly any in fact:

my .kde4/share/config/kwinrc
[$Version]
update_info=kwin.upd:kde3.0r1,kwin.upd:kde3.2Xinerama,kwin3_plugin.upd:kde3.2,kwin_focus2.upd:kwin_focus2,kwin_focus1.upd:
kwin_focus1,kwin_on_off.upd:kwin_on_off

[Desktops]
Name_1=
Name_2=
Name_3=
Name_4=
Number=4

it's properties:
ls /mnt/b5/juk4/.kde4/share/config/kwinrc -l
-rw------- 1 julien users 226 May 31 10:28

This way it looked when I watched id after logging in as julien under kde3.5.
But when logging in to my kde4 user juk4 on suse 11.2, and subsequently
logging in under a console, the properties were identical. So appearantly the
options in the file don't change (no new options are presented) under 11.2

Could this be seen as a 11.2-error?
--
Julien Michielsen
julien_at_michkloo.xs4all.nl

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups