Mailinglist Archive: opensuse (1196 mails)

< Previous Next >
Re: [opensuse] Slow CIFS mount
  • From: PaulFransen <send.me@xxxxxxxxx>
  • Date: Thu, 28 Jan 2010 13:47:14 +0100
  • Message-id: <201001281347.14341.send.me@xxxxxxxxx>
On Wednesday 06 January 2010 16:20:56 Ciro Iriarte wrote:
Hi, i'm seeing 1 to 3 minutes delay mounting on OS 11.2 a CIFS share
from a Windows XP machine. Once it's mounted, everything is fine.
Anybody sees something like this?

Regards,

--
Ciro Iriarte
http://cyruspy.wordpress.com
--

Hi Ciro,

I don't think that this is a bug.

I have a samba share residing on a OpenSUSE 11.2 machine. Mounting this share
on a Windows XP machine poses no speed problem at all (at least when you
accept the usual Windows speeds). However, mounting this share on another
OpenSUSE 11.2 machine takes a couple of minutes. I am using the command:
/sbin/mount.cifs //[ip address server]/[share name] /[mount point] \
-o user=[user name],password=[password],rw
Once mounted after a delay, the share is accessible with very acceptable
speeds.

When you look in
man 8 mount.cifs
the explanation of the "port=" parameter reads:
"If the CIFS server is not listening on this port or if it is not
specified, the default ports will be tried i.e. port 445 is tried
and if no response then port 139 is tried."
Indeed, when using the following mount command:
/sbin/mount.cifs //[ip address server]/[share name] /[mount point] \
-o user=[user name],password=[password],rw,port=139
the share is mounted instantaneously. This would suggest that the delay
results from contacting the server first at port 445 and only after that at
port 139.

Samba servers are listening to ports 445 and 139 by default. However, most
authors recommend to keep firewall port 445 closed, e.g.
http://en.opensuse.org/Firewall_on_simple_samba_LAN. Opening this port in the
server firewall, or specifying port=139 in the mount.cifs command on the
client, does the trick in my situation.

I have added a comment to https://bugzilla.novell.com/show_bug.cgi?id=569384
as well.

Best regards,

Paul.


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References