Mailinglist Archive: opensuse (1194 mails)

< Previous Next >
[opensuse] Problems (minor?) with 11.2 upgrade
  • From: "John E. Perry" <j.e.perry@xxxxxxx>
  • Date: Mon, 04 Jan 2010 03:06:12 -0500
  • Message-id: <4B41A174.7050002@xxxxxxx>
After seeing a lot of praise for 11.2, and not having seen the early
complaints about its killing Intel networking, I decided to upgrade.

I followed the instructions provided on the "Upgrade/Supported" page of
the wiki. Things went pretty well, I think.

One hitch is that I needed two iterations of

zypper dup

after I'd done all the preparatory actions. When I did the first dup it
crunched for 2-1/2 hours installing thousands of packages. I got some
warnings about running processes that needed to be restarted. Since
there had been a kernel upgrade, I simply restarted the computer.

Panic followed :-). Several blank dialogs popped up. Worse yet, when I
started yast to do an online update the progress box was blank. So I
went back to the command line and did a

zypper up

Nothing to do. Meantime more blank dialogs popped up. Willing to try
anything, I did another

zypper dup

It installed hundreds more packages. One of the messages mentioned a
2.6.29... kernel, which I recalled was in 11.1.

So I rebooted again. Now uname -a says

Linux embelex 2.6.31.5-0.1-pae #1 SMP 2009-10-26 15:49:03 +0100 i686
i686 i386 GNU/Linux

so I guess I'm ok. I tried

embelex:~ # zypper up
Loading repository data...
Reading installed packages...

Nothing to do.

then

embelex:~ # zypper dup
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
3 Problems:
sesam_srv-3.0.1-171.1.1.i586
kdm-branding-upstream-4.3.1-7.5.i586
kio_sysinfo-branding-upstream-11.2-3.2.noarch

(above slightly edited for clarity). I skipped all of them since they
don't appear to be particularly useful (except possibly sesam -- I don't
know what it is). I had installed the branding-upstream to see if kde
looked better than suse, which i suppose is the reason for the upstream
branding warnings. Now I can't get rid of them without downgrading
dozens of other packages.

So far things look good. Firefox is up to 3.5.6 and seems to work well;
Tbird is up to 3.0 and looks good; skype still appears to work (can't
test it on people at 0200, but the test call was good :-).

Oh yeah. wifi doesn't work any more. One of the 11.1 updates broke it,
and I was hoping 11.2 would fix whatever that was. It's still doing the
same thing it was before: knetworkmanager shows me my SSID, I click on
it, it churns for a while, and comes back asking for my passphrase. I
give it, and {repeat ad infinitum}.

Earlier in 11.1, knetworkmanager simply connected and after a few
seconds, I was online again. I didn't need to do anything manually.

So I'm still on ethernet.

John Perry
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >