Mailinglist Archive: opensuse (1194 mails)

< Previous Next >
Re: [opensuse] What I had to do to get wireless communication
  • From: Stan Goodman <stan.goodman@xxxxxxxxxxxxx>
  • Date: Fri, 1 Jan 2010 14:16:55 +0200
  • Message-id: <201001011416.55681.stan.goodman@xxxxxxxxxxxxx>
At 13:45:51 on Friday Friday 01 January 2010, "Carlos E. R."
<robin.listas@xxxxxxxxxxxxxx> wrote:
On Thursday, 2009-12-31 at 19:35 +0200, Stan Goodman wrote:
I have a new router (D-Link DIR-615) and a new wireless card (Intel
5300agn) in my notebook machine, and was unable to establish
communication between them. After several days of puzzlement, I began
to entertain the notion that one or both were defective.

In an effort to establish which, I connected an external HD in place
of that of the notebook machine, installed WinXP on it, and installed
the wireless card's driver on it; the card worked properly, so it was
no longer suspect.

I thought I would them have to devise a troubleshooting scheme for
the router, but when I tried to use the wireless card to go online
with my own router, it worked perfectly. I had made no changes
whatever in any configuration.

You mean it now works in Linux?

It sees and communicates with everything here, i.e. Linux, printer, VoIP
adapter.

If someone can explain what made the difference, I will stop
believing in poltergeists.

Did you power off? I'll made a wild guess. Or two. :-)

It was powered off any number of times.

Windows loaded a firmware to the card. When you reboot without powering
off, it is still there and linux works.

That has since occurred to me, in spite of which it may be the right
answer. I know that some (all?) similar cards require firmware
installation, but as far as I could learn or guess, the fact that the
driver is in the kernel by default implied that the rpm would deal with
that too, and I would not have to do so explicitly. If Windows does
install the firmware along with the driver, it's fair to ask why Linux
doesn't as well. I still do not see a place in oS at which I should or
could have installed firmware by myself.

Or, windows changed a setting or something in the card that makes it
works. It works in linux then because the setting holds.

Lets see whats happens after a hard reset or power-off >:-)

The Windows experiment took place in Haifa; I live 20km away. Setting the
router up at home meant it had already survived a power down/up cycle. It
has already lived through another all last night.

Cheers,

Hoping that all here have had their Sylvester "cheers", and recovered from
the resulting hangover, A Healthy, Happy, Prosperous, and Peaceful 2010
to all.
Carlos E. R.



--
Stan Goodman
Qiryat Tiv'on
Israel
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References