Mailinglist Archive: opensuse (1596 mails)

< Previous Next >
[opensuse] Bug in xmms2 dependencies - packman (fyi)
  • From: "David C. Rankin" <drankinatty@xxxxxxxxxxxxxxxxxx>
  • Date: Thu, 29 Oct 2009 22:37:39 -0500
  • Message-id: <200910292237.39298.drankinatty@xxxxxxxxxxxxxxxxxx>
Listmates,

Attempting to install xmms2, the core part complains that it cannot be
installed because there are no installable providers of libx264.so.60, and
thus the package cannot be installed. The actual conflict file is:

#### YaST2 conflicts list - generated 2009-10-29 22:22:20 ####

nothing provides libx264.so.60 needed by
libavcodec51-0.4.9svn-20080906.pm.0.i586

[ ] do not install xmms2-core-0.4-1.pm.4.i586




#### YaST2 conflicts list END ###


Checking the system with locate libx264.so.60 reveals:

/usr/lib64/libx264.so.60

Is already installed? What gives? Something is wonky with dependencies
lately
because this isn't the only case where yast/zypper has complained about a
dependency that is already installed.

Now I know that packman packages are not the responsibility of
opensuse, and
I also know that the error references and i586 package of libavcodec51, but
the point is that this seems strange and I need to know if this is normal or
if there is a problem with dependencies that is larger than this one instance.

So first, has anyone else experienced this behavior? And, second, even
if you
haven't, any idea why I get an i586 dependency error on an x86-64 box where
the x86-64 shared object file is already installed?


--
David C. Rankin, J.D.,P.E.
Rankin Law Firm, PLLC
510 Ochiltree Street
Nacogdoches, Texas 75961
Telephone: (936) 715-9333
Facsimile: (936) 715-9339
www.rankinlawfirm.com
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >