Mailinglist Archive: opensuse (1599 mails)

< Previous Next >
Re: [opensuse] ntp and wireless
  • From: Roger Oberholtzer <roger@xxxxxx>
  • Date: Thu, 29 Oct 2009 08:34:54 +0100
  • Message-id: <1256801694.6144.6.camel@xxxxxxxxxxxx>
On Wed, 2009-10-28 at 22:26 +0100, Roger Oberholtzer wrote:
On Wed, 2009-10-28 at 20:28 +0100, Will Stephenson wrote:

See /etc/NetworkManager/dispatcher.d/.

Ahh. I think this is the thing I am looking for. I think a script like
this might work:

#! /bin/sh
case "$2" in
up) rcntp start
;;
down) rcntp stop
;;
*) exit 0
;;
esac


Note, I have not tried it yet. But I will shortly

I have tried this, and it does not seem to work.

I tried:

1. run the script by hand to be sure there is nothing odd there. It runs
as expected.

2. With ntp running, turn off wireless via NetworkManager. (This is what
the icon in my KDE system tray is eventually talking to, right?)

I expected the ntp daemon to go away. Nope. It is still running.

3. With ntp not running, connect to my wireless access point.

I expected the ntp daemon to be started. Nope. It is not running.

I read the man page, and the script permissions are as it says (and the
same as the scripts that are already there).

So, either the kde system tray icon is not connected to this, or
something is amiss.

This is with openSUSE 11.2 RC1

As suggested elsewhere, I can of course do by hand:

rcntp start|stop|restart

But that is not the point.

--
Roger Oberholtzer

OPQ Systems / Ramböll RST

Ramböll Sverige AB
Krukmakargatan 21
P.O. Box 17009
SE-104 62 Stockholm, Sweden

Office: Int +46 8-615 60 20
Mobile: Int +46 70-815 1696

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups