Mailinglist Archive: opensuse (1599 mails)

< Previous Next >
[opensuse] Connecting to an openVPN Server
  • From: Sebastian Schöbinger <sebastian.sts301@xxxxxxxxx>
  • Date: Sat, 17 Oct 2009 21:06:14 -0400
  • Message-id: <200910172106.14662.sebastian.sts301@xxxxxxxxx>
Hi guys

I have a problem connecting to an openVPN server, I tried it few times with
KVpnc, but the log is all the time like that:

debug: Preserving network environment
debug: openvpn: /usr/sbin/openvpn
debug: Support for TUN/TAP found (compiled into kernel or kernel module
already loaded).
debug: CmdBeforeConnectScript:
/root/.kde4/share/apps/kvpnc/cmd_before_connect_script.lan
debug: Executing command before connect: --script-security
debug: "CmdBeforeConnectScript" started.
error: [CmdBeforeConnect err]
/root/.kde4/share/apps/kvpnc/cmd_before_connect_script.lan: line 1: --script-
security: command not found
error: [CmdBeforeConnect err]
debug: "CmdBeforeConnectScript" finished.
debug: Default interface: "eth0".
debug: IP address of default interface: "192.168.0.109".
info: Trying to connect to server "###server###" with ...
debug: Setting DNS_UPDATE "Yes".
debug: Starting Openvpn management handler...
info: Send username...
info: Send password...
debug: [openvpn] Sat Oct 17 20:53:09 2009 WARNING: No server certificate
verification method has been enabled. See http://openvpn.net/howto.html#mitm
for more info.
debug: [openvpn] Sat Oct 17 20:53:09 2009 NOTE: the current --script-security
setting may allow this configuration to call user-defined scripts
debug: [openvpn]
debug: [openvpn] Sat Oct 17 20:53:10 2009 WARNING: this configuration may
cache passwords in memory -- use the auth-nocache option to prevent this
debug: [openvpn]
debug: Disconnect requested
debug: Disconnect requested, status connecting
debug: Killing process while connecting.
success: Successful connect try canceled.
error: OpenvpnManagementHandler: The remote host closed the connection
debug: Disconnected.

After a while I just disconnected.
I also tried it with KNetworkmanager, but there it tries to connect and stops
at some time.
Is there a log where I can find the problem, why it didn't connect?

Running on openSUSE 11.1 M6 and De 4.3.1
----------
mfg / best
Sebastian Schöbinger

//Member of the openSUSE Team //
//Writer of the openSUSE News (Tips and Tricks) //
//Translator of the openSUSE News //
//http://en.opensuse.org/User:STS301 //
//http://linux301.wordpress.com //
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups