Mailinglist Archive: opensuse (1599 mails)

< Previous Next >
Re: [opensuse] Windows 98SE can't access Samba openSUSE 11.1
  • From: Paul Neuwirth <mail@xxxxxxxxxxxxxxxx>
  • Date: Sat, 10 Oct 2009 23:00:15 +0200 (CEST)
  • Message-id: <Pine.LNX.4.64.0910102252270.8124@xxxxxxxxx>
Possibly "lanman auth = yes" will do it.

It's weired... I tried some different settings, with following results:
letting Windows send encrypted passwords, encrypted passwords enabled in
smb.conf (with ntlm auth/lanman auth or only one of both...) leads to
the mentioned error. disabling encrypted passwords in smb.conf makes
windows say "invalid parameter" on connecting. turning password
encryption off on both sides, it works! but i think with having password
encryption disabled the windows NT style clients won't have acces
anymore. Before the update the crypted way worked...
I also increased the verbosity of the logs, some interesting lines could
be:
check_ntlm_password: sam authentication for user [XYZ] FAILED with
error NT_STATUS_WRONG_PASSWORD
check_ntlm_password: Authentication for user [XYZ] -> [XYZ]
FAILED with error NT_STATUS_WRONG_PASSWORD
the user is previously recognized.


Adam hit the nail on the head. The lanman auth parameter is what you need. You
will also want to upgrade samba. There were a few releases that had bugs with
that setting after it was disabled by default.

http://download.opensuse.org/repositories/network:/samba:/STABLE/openSUSE_11.1/

Thanks for the fast help. I just upgraded to the latest Samba Version
samba-3.4.2-1.1 (also updated all corresponding packages). No
problems
with the Windows NT as before. But Windows
98SE doesn't even find the server anymore in the network neighborhood.
Even accessing by \\IP doesn't work.
Getting following error on connecting of network devices:
The following error occured while reconnecting [...]
Permanent connection not available.
I set the samba logs to max verbosity but getting no entry at all.
No firewall is blocking the network interface.
Here the global part of my smb.conf:
# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2006-11-27
[global]
workgroup = PANE
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
usershare allow guests = No
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody
-s /bin/false %m$
domain logons = Yes
domain master = Yes
netbios name = PANE
security = user
passdb backend = smbpasswd:/etc/smbpasswd
local master = Yes
os level = 65
preferred master = Yes
wins support = Yes
encrypt passwords = Yes
lanman auth = Yes
ntlm auth = Yes
log level = all:10

Thanks for further assistance,
Paul
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups