Mailinglist Archive: opensuse (1503 mails)

< Previous Next >
Re: [opensuse] Re: Partitioning problem in installing oS v11.1
  • From: Greg Freemyer <greg.freemyer@xxxxxxxxx>
  • Date: Thu, 1 Oct 2009 09:45:34 -0400
  • Message-id: <87f94c370910010645q398e0799ja174e7189e97dfb0@xxxxxxxxxxxxxx>
On Thu, Oct 1, 2009 at 9:32 AM, Stan Goodman <stan.goodman@xxxxxxxxxxxxx> wrote:
At 14:23:39 on Thursday Thursday 01 October 2009, Per Jessen
<per@xxxxxxxxxxxx> wrote:
Stan Goodman wrote:
as somebody else said, why don't you use YaST installer to do the
partitionning?

Among other reasons, because I want to know why the installer has
retained partition information that isn't there anymore, and where it
is storing obsolete information.

Partition information is stored in the partition tables.  When the
partitioner finds your old partition scheme it's because it is still
stored there.

I don't know dfsee either, I always use fdisk - what does fdisk says
when you print the partition table?

I know that the partition tables store the partition scheme. But if I see
a certain arrangement, that must be what the partition table is storing.

I think, in fact, that HDs have two copies of the partition table. If that
is true, it means that DFSee (and almost certainly fdisk as well) is
looking at one of them, and the oS installer is l ooking at the other. I
have to track that down. And if the situation is as I guess, I do not
think it would be wise to leave the discrepancy as is and simply go over
to the installer's partitioner, because the confusion might well cause
some sort of trouble in the future.

I will post here how this turns out, for the interest of others.

DFSee, by the way, is among other things an alternative to fdisk, but much
more versatile -- and it works with Linux, Windows, Mac (I think), and
OS/2.  You can look at its website, or  ask e.g. Felix Miata (or anyone
else who came from OS/2) about it.

--
Stan Goodman

Stan / JDD,

I suspect opensuse is doing something strange with partitioning recently.

I was testing factory last week and used fdisk to create an extended
partition (/dev/sda7).

I then went into yast2 partitioner and it said parted could not read
my partition table and therefore I would only get a read only view
that was my disk without /dev/sda7.

I also tried to add /dev/sda7 to lvm via "pvcreate /dev/sda7". It
told me that /dev/sda7 was an illegal partition. (See my thread on
the factory list for details.)

It was recommended I delete /dev/sda7 and recreate it witl yast2
partitioner. To my great surprise, after I deleted it, yast2
partitioner had no issues opening the disk / partition table and
allowing me to add the partition.

And then I went back to the command line and pvcreate /dev/sda7 worked.

I don't know what is going on, but I don't like that fdisk is no
longer a supported way to add partitions (if that is the case.) No
one explicitly said that, but no one said my observed behavior was a
bug either.

If someone wants to do more testing on this and add a bugzilla, I'd be
curious how the developers respond.

Greg
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups