Mailinglist Archive: opensuse (1473 mails)

< Previous Next >
Re: [opensuse] 11.1 nfs and samba problems
  • From: kanenas@xxxxxxxxxxxxx
  • Date: Tue, 30 Jun 2009 02:55:27 -1000
  • Message-id: <200906300255.27944.kanenas@xxxxxxxxxxxxx>
On Tuesday 30 June 2009 01:34:13 am Lars Müller wrote:
On Mon, Jun 29, 2009 at 10:17:29PM -1000, kanenas@xxxxxxxxxxxxx wrote:
a few days ago i posted that my month old 11.1 suse install suddenly
lost the ability to start the nfs server automatically or from Yast, now
the server only starts from the command line. today i found out that the
samba server is also screwed up, something about the smbfs not being
capable of starting,

The smbfs init script mounts any cifs file system defined in /etc/fstab
or /etc/samba/smbfstab

No cifs filesystems in either one. regarding other files in /etc/samba,
dhcp.conf shows 27 June mod date, secrets.tdb was modified on 21
June -that's the most probable date I lost my samba- and i myself changed the
smbpasswd file on 28 June. the remaining files have a 20 march date.


Only by historical reasons it is still named smbfs. We'll rename it
soon to cifs. Such a rename might lead to an activated cifs service
even if the administrator disabled smbfs in the past. Unfortunately we
don't see an alternative to this rename approach.

yes, i know a couple of very general things about that, but what i know does
not qualify me for any comment on the subject.



also an old, circa suse 9.2 complaint about "can not write pam settings"
when trying to install windows membership in yast.

Even 'circa' 9.2 is ancient and no longer fed with security updates.
And IIRC the rename of the YaST module to 'windows domain membership'
happened in the time of 10.1. Therefore your report sounds a bit
strange.

The "circa 9.2" comment you dislike is just a reference to old posts about
the "can not write to pam settings " popup. you can find them with 2003 dates
on the first page of a google search on the subject.


this is a vanilla install, with the addition of kernel sources (for
vmware install), the basic suse repositories, also packman and vlc for
the multimedia apps, the only kde ever installed and used has been kde3.
again, both samba and nfs were working fine a week ago. it is very
probable that some "security update" did the damage,

No. This is very unlikely.

but I have allready tried the
downgrade s to samba and winbind without success.

Two things came again into my mind:

a) Never ever provide the particular version you use.

Tried 3.2.7-11.2.1-x86_64 from repo update
also 3.2.6-0.3.1-x86_64 from repo update
and 3.2.4-5.2-x86_64 from repo-oss

winbind versions are 3.2.7-11.21-x86_64, 3.2.6-0.3.1-x86_64 and
3.2.4-5.2-x86_64.

all were installed with yast

uname -r spits out 2.6.27.23-0.1-default.

all were simply summarised in the "latest updates" statement.

'circa' 9.2 is a
perfect example how a report should be handled. I'll suggest to the
bugzilla team to add such a product version. :)

With other words: Providing as much as possible and correct information
with the initial posting or bugreport makes it much easier (if not even
possible) to handle the issue. And unbelievable but true there is even
a dedicated page about how to report a (samba) bug in the openSUSE wiki.

I gave up on that page a couple of years ago. don't know how user friendly it
is today, but it used to be directed at the developers, not the simple users.

See http://en.opensuse.org/Submitting_Bug_Reports

b) Please define 'downgrade' as there are different ways to perform
this.

downgrade: In the SUSE OS I always downgrade using Yast. whenever possible i
first delete the package, then click on an earlier version and click
on "accept". of course usually the deps are just too many for an outright
deletion, then i just click on a lower version and select the "upgrade"
button,( oh, how doze-like our yast has become(:)

What might happened is the following: As soon as you uninstall a
component which provided an init script - as both packages samba and
samba-winbind do - the uninstall ensures to remove the sym links to
start and stop the no longer available service.
hoooold it here for a second, please! I know that yast is not perfect, but
using it to remove a package and install a n earlier version should be and
mostly is rather painless and does not involve erasing of config scripts.


And your new install does not activate the service.

pointers to start smbfs would be greatly appreciated.(smb does report up and
running, winbind does start with yast.)

i am sure you can provide many examples of shut down services, however i can
not see yast doing that in general. trying to start smbfs thru yast system
services complains about smbfs start not being configured!!! i have been
using samba in suse for many years, but never had to do that .
this one might be a yast related thing, i just can not see three versions of
samba with such a huge problem.

This is a
reasonable, defensive approach. Cause a not running service can't
provide any weak point.

actually a non running service does not provide *any* point of *any* strength,
so how about a little more positivity here. what's this, a typical
pre-emptive strike?
:)



Lars

d.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References