Mailinglist Archive: opensuse (1473 mails)

< Previous Next >
Re: [opensuse] athlon unable to run qemu-kvm, poosibly caused by cpu-parameter
  • From: Michal Hrusecky <mhrusecky@xxxxxxx>
  • Date: Mon, 22 Jun 2009 12:51:16 +0200
  • Message-id: <20090622105116.GC13532@xxxxxxxxxxxxxxxxxxxxxxxxxx>
Julien Michielsen - 10:57 22.06.09 wrote:
I tried to get WinXP installed under kvm, and noticed I could not get it
installed, because the MS-Win setup-procedure got confused.  I had run two
commands:
qemu-img create  -f qcow2 ./winxp.img 10G
this command worked fine, to prepare a WinXP- immage on disk (in direc-
tory  /mnt/a14).
Secondly I wanted to install the XP on disk such that qemu-kvm can work on
it,
and therefor I used the command
qemu-kvm -M pc -m 1G -cpu athlon -cdrom /dev/sr0 -boot d /mnt/a14/winxp.img

Having given this command the Windows setup started to run, but ended in
failure with the message
"Cannot load file SETUPREG.HIV into memory. Errorcode is 3072. Push any
key to
stop the installation program"
Even though setup complained of not being able to find the SETUPREG.HIV-file,
this file was present in the subdirectory I386 of the Win-XP-CD.  I assume
the setup-procedure got confused by the cpu-parameter of the qemu-kvm -
command: qemu-kvm  -cpu athlon.
If the parameter had had i386 as its value, I suppose the setup-procedure of
MS-Win would have searched the I386 directory, and everything had worked
fine.
Is this a known problem of the installation of WinXP under qemu-kvm, and does
a work-around exist?  If I could use my present allready installed
XP-version on a
separate partition as an input to the qemu-kvm command (instead of the MS Win
CD) the problem might be side-stepped. Is this possible at all?
Thanks for your interest.

I didn't run into the same problem, but I'm using several virtual
machines with kvm and I never needed to specify -M or -cpu. I thought
that specific CPU is supported only by qemu with disabled kvm support
and to make use of kvm I never used -M or -cpu with kvm. Anyway athlon
can be probably treated as i386 and I guess Windows detects only
architecture (if they support any other architecture then i386). I would
try to use image of CD-ROM on my disk instead of real cdrom. I guess it
using real cd-rom can make things response slower and confuse windows.
And you can use your existing installation on hdd in kvm, although I'm
not sure if windows are able to handle such a hardware change. But it
would be quite dangerous, if you'll access same partition from two
different places... It can lead to filesystem inconsistency. You can
use

kvm -hda /dev/sda

but as this is really dangerous unless you are sure that you will use
it in right way and you've got good bootloader and you know what are you
doing, I wouldn't suggest it. I'll recommend you to try to install your
windows using cdrom image first.

--
Michal Hrusecky

Package Maintainer
SUSE LINUX, s.r.o
e-mail: mhrusecky@xxxxxxx
< Previous Next >
References