Mailinglist Archive: opensuse (1473 mails)

< Previous Next >
[opensuse] athlon unable to run qemu-kvm, poosibly caused by cpu-parameter
  • From: "Julien Michielsen" <julien@xxxxxxxxxxxxxxxxxx>
  • Date: Mon, 22 Jun 2009 10:57:12 +0200 (CEST)
  • Message-id: <64967.80.101.53.239.1245661032.squirrel@xxxxxxxxxxxxxxxxx>
I tried to get WinXP installed under kvm, and noticed I could not get it
installed, because the MS-Win setup-procedure got confused.  I had run two
commands:
qemu-img create  -f qcow2 ./winxp.img 10G
this command worked fine, to prepare a WinXP- immage on disk (in direc-
tory  /mnt/a14).
Secondly I wanted to install the XP on disk such that qemu-kvm can work on
it,
and therefor I used the command
qemu-kvm -M pc -m 1G -cpu athlon -cdrom /dev/sr0 -boot d /mnt/a14/winxp.img

Having given this command the Windows setup started to run, but ended in
failure with the message
"Cannot load file SETUPREG.HIV into memory. Errorcode is 3072. Push any
key to
stop the installation program"
Even though setup complained of not being able to find the SETUPREG.HIV-file,
this file was present in the subdirectory I386 of the Win-XP-CD.  I assume
the setup-procedure got confused by the cpu-parameter of the qemu-kvm -
command: qemu-kvm  -cpu athlon.
If the parameter had had i386 as its value, I suppose the setup-procedure of
MS-Win would have searched the I386 directory, and everything had worked
fine.
Is this a known problem of the installation of WinXP under qemu-kvm, and does
a work-around exist?  If I could use my present allready installed
XP-version on a
separate partition as an input to the qemu-kvm command (instead of the MS Win
CD) the problem might be side-stepped. Is this possible at all?
Thanks for your interest.

-W-
Julien Michielsen
julien@xxxxxxxxxxxxxxxxxx


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups