Mailinglist Archive: opensuse (1473 mails)

< Previous Next >
[opensuse] Wine 1.1.24 Bad file descriptor errors?
  • From: Clayton <smaug42@xxxxxxxxx>
  • Date: Sun, 21 Jun 2009 22:05:27 +0200
  • Message-id: <e29967880906211305u3cc604b0paa8d1b24635c52a@xxxxxxxxxxxxxx>
I just bumped my Wine build to the latest 1.1.24 release. Now when
attempting to run any apps I get this error:

wine client error:XX write: Bad file descriptor
(where XX is some hex value)

and the app will crash.

I've wiped the .wine directory and started fresh... still happening.
If I roll back to 1.1.23 everything works OK. If I run the Windows
apps as root I can "get around" the error - but obviously running as
root is not exactly a good idea.

This error pops up on every executable that I run with 1.1.24...
either with previously installed apps or wiht a clean/new .wine and
attempting to reinstall apps. The apps can be any Windows app that
would normally run OK in Wine... eg even the "supported" extras from
winetricks

Any ideas on where else I can look for what is (or could be) causing this?

I've done a search on this, and only get a few hits.. mostly from
quite a long time ago within the Wine project, but no real answer was
ever given... at least not that I've seen so far.

C.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups