Mailinglist Archive: opensuse (1473 mails)

< Previous Next >
Re: [opensuse] editor that does not eat out TAB characters
  • From: Maura Monville <mauede@xxxxxxxxx>
  • Date: Tue, 16 Jun 2009 08:49:35 +0000 (GMT)
  • Message-id: <91721.32791.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx>

I did installed python-idle from Yast which requested SuSE 11.1 DVD ... I hope
it is the same as the one that zypper would have installed.

Anyway, no new applet or icon has been added to the Application menu.
I tried to launch it from terminal command line but I do not know where Yast
placed it.

mauede@linux-326k:~> which python-idle
which: no python-idle in

mauede@linux-326k:~> which idle

So I launched as above:
mauede@linux-326k:~> /usr/bin/idle
IDLE Subprocess: socket error: Connection refused, retrying....

It opened up a window. I assume I have to use such a window to debug the python
I have always used debugger with compiled code ... so I feel at a loss.
I need to run the python script passing a parameter and do not know how to do.
Is there an IDLE demo ?

Thank you very much,

----- Messaggio originale -----
Da: Anthony Simonelli <asimonelli01@xxxxxxxxx>
A: opensuse@xxxxxxxxxxxx
Inviato: Martedì 16 giugno 2009, 7:59:45
Oggetto: Re: [opensuse] editor that does not eat out TAB characters

On Monday 15 June 2009 04:01:16 pm Maura Monville wrote:

Personally I do hate Windows. Although, in certain environments the
development platform, and even the tools, are imposed ... take irt or leave

My current problem stems from my ignorance about python. On top of that I
have to use the undocumented python code written by an Ms. student who
decided to leave the Computer Science program when he was just a couple of
weeks from defending his thesis. A crazy behaviour that nobody expected.
By trial and error I succeeded in getting the python script run to completion
without any error. But the oputut it generates is not what was expected.
Basically the python script is supposed to extract automatically some data
from the miRecords data base which is public and available in form of
structurated HTML web pages.
I understand where the python script gets the raw data (miRecords). But I
cannot understand where it stores the information it is supposed to extract.
It looks like the script is trying to store the info into a local database
that might be
MySql or SQLight. Since I cannot see any call or link to either databases, I
tried to run the python script step-by-step.
Since python is a scripting language I would expect to be able to accomplish
that just copying llines from the script and pasting them onto a python
terminal shell. But, regardless of which editor I use, python interpreter
prints out plenty of "indentation error " messages.
I tried an interactive graphic debug session by typing #ddd pbd ... which
brought up a nice GUI expecting an executable to be uploaded (sigh !).
I did not install pydbg as no rpm file is provided (as far as I know) and its
installation procedure from source code is not clear to me. I do not know
whether the standard steps (configure, make, make install) can be applyed to
a scripting language.
I am appalled at a modern object-oriented language that is built on a suyntax
which is sensistive to indentation !

I hope I won't irritate anyone if I post some excerpts of my pdb debugging
attempts ... maybe they will be meaningful for
pythons experienced users.

I suggest using IDLE (zypper install python-idle). This program was written in
Python using the Tkinter GUI toolkit. It provides an interpreter interface as
well as an editor. The editor allows you to write Python scripts easily with
auto-indentation and syntax highlighting. It uses a lot of conventions that a
lot of Python programmers use when writing their code. It even has help on the
syntax of functions at the interpreter. Worth a try.
Thank you,

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >