Mailinglist Archive: opensuse (1473 mails)

< Previous Next >
Re: [opensuse] help debugging a failed zypper upgrade?
  • From: Jano Kupec <jkupec@xxxxxxx>
  • Date: Wed, 10 Jun 2009 11:36:00 +0200
  • Message-id: <4A2F7E80.6070709@xxxxxxx>
Thanx Richard for reporting this.

Just in case anybody wonders, the explanations are here:

http://bugzilla.novell.com/show_bug.cgi?id=509191
http://bugzilla.novell.com/show_bug.cgi?id=511523

cheers,
jano

PGNet Dev wrote:
i've been running zypper/aria2 from /HEAD for a bit; updates from
repos have been fine. a few days ago, the repos 'forced' a downgrade.
once accepted (for a test) ...

(1) i'm trying to 'read' the zypper "offer" below to figure out which
_specific_ rpms are _preventing_ an upgrade without deinstalling a
bunch. from the output below, to me it's not clear if one. or many,
rpms are actually the 'culprit'.
(2) if it's a repos-out-of-sync issue, who do we contact to get it fixed?

details:

egrep "base|prio" {Zypp*,Yast*,Netutils*,OS11-update*,OS11-oss*}

ZyppHEAD.repo:baseurl = .../repositories/zypp:/Head/openSUSE_11.1
ZyppHEAD.repo:priority = 10
YastHEAD.repo:baseurl = .../repositories/YaST:/Head/openSUSE_11.1
YastHEAD.repo:priority = 10
Netutils.repo:baseurl = .../repositories/network:/utilities/openSUSE_11.1
Netutils.repo:priority = 10
OS11-update.repo:baseurl = .../update/11.1
OS11-oss.repo:baseurl = .../distribution/11.1/repo/oss

rpm -qa | grep ^zypper
zypper-1.0.9-0.1.1 <---- CURRENT

zypper se -s | grep -i "| zypper"
v | zypper | package | 1.1.2-81.1 | x86_64 |
ZyppHEAD <--- AVAIL
v | zypper | package | 1.1.2-81.1 | i586 | ZyppHEAD
i | zypper | package | 1.0.9-0.1.1 | x86_64 | OS11-update
v | zypper | package | 1.0.5-2.1.2 | x86_64 | OS11-update
v | zypper | package | 1.0.2-1.5 | x86_64 | OS11-oss
v | zypper | package | 1.0.9-0.1.1 | i586 | OS11-update
v | zypper | package | 1.0.5-2.1.2 | i586 | OS11-update
v | zypper | package | 1.0.2-1.5 | i586 | OS11-oss
| zypper | srcpackage | 1.1.2-81.1 | noarch | ZyppHEAD
| zypper | srcpackage | 1.0.9-0.1.1 | noarch | OS11-update

zypper up zypper

Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: cannot install both zypper-1.1.2-81.1.i586 and
zypper-1.0.9-0.1.1.x86_64
Solution 1: Following actions will be done:
install zypper-1.1.2-81.1.x86_64 (with vendor change)
openSUSE
-->
openSUSE Build Service
install yast2-ncurses-pkg-2.18.4-5.1.x86_64 (with vendor change)
openSUSE
-->
openSUSE Build Service
deinstallation of yast2-pkg-bindings-2.17.38-0.1.1.x86_64
install yast2-qt-pkg-2.18.9-1.3.x86_64 (with vendor change)
openSUSE
-->
openSUSE Build Service
downgrade of libqdialogsolver1-1.2.9-1.1.1.x86_64 to
libqdialogsolver1-1.2.6-243.1.x86_64
install libqdialogsolver1-1.2.6-243.1.x86_64 (with vendor change)
openSUSE
-->
openSUSE Build Service
deinstallation of yast2-packager-2.18.8-4.13.x86_64
deinstallation of yast2-bootloader-2.18.8-3.8.x86_64
deinstallation of yast2-country-2.18.5-2.23.x86_64
deinstallation of yast2-online-update-2.18.2-2.25.noarch
deinstallation of yast2-2.18.16-4.8.x86_64
deinstallation of yast2-registration-2.17.17-2.22.noarch
deinstallation of autoyast2-installation-2.18.5-2.8.noarch
deinstallation of autoyast2-2.18.5-2.8.noarch
deinstallation of yast2-add-on-2.18.3-2.25.noarch
deinstallation of yast2-metapackage-handler-0.8.9-2.21.noarch
deinstallation of yast2-iscsi-client-2.18.6-2.21.noarch
deinstallation of yast2-installation-2.18.15-5.6.noarch
deinstallation of yast2-inetd-2.17.3-2.22.noarch
deinstallation of
yast2-registration-branding-openSUSE-2.17.17-2.22.noarch
deinstallation of yast2-repair-2.18.2-2.23.noarch
deinstallation of yast2-restore-2.18.1-2.23.noarch
deinstallation of yast2-tune-2.18.1-2.23.x86_64
deinstallation of yast2-users-2.18.3-2.25.x86_64
deinstallation of yast2-update-2.18.5-5.12.x86_64
deinstallation of yast2-online-update-frontend-2.18.2-2.25.noarch
deinstallation of yast2-samba-server-2.18.1-2.22.noarch
deinstallation of yast2-backup-2.18.4-2.25.noarch
deinstallation of yast2-irda-2.17.2-2.23.noarch
deinstallation of yast2-firewall-2.18.0-2.23.noarch
deinstallation of yast2-kerberos-server-2.18.0-2.25.noarch
deinstallation of yast2-ldap-client-2.18.1-2.25.noarch
deinstallation of yast2-mail-2.18.0-2.22.noarch
deinstallation of yast2-apparmor-2.18.3-2.23.noarch
deinstallation of yast2-ntp-client-2.18.0-2.19.noarch
deinstallation of yast2-sudo-2.18.2-2.22.noarch
deinstallation of yast2-kerberos-client-2.17.6-2.20.noarch
deinstallation of yast2-nfs-client-2.18.0-2.23.noarch
deinstallation of yast2-pam-2.17.1-2.23.noarch
deinstallation of yast2-runlevel-2.17.4-2.23.noarch
deinstallation of yast2-samba-client-2.17.11-2.20.noarch
deinstallation of yast2-security-2.17.12-2.20.noarch
deinstallation of yast2-sysconfig-2.17.0-2.23.noarch
deinstallation of yast2-vm-2.16.10-2.13.x86_64
deinstallation of yast2-profile-manager-2.17.1-2.22.x86_64
deinstallation of yast2-ldap-2.17.3-2.22.x86_64
deinstallation of yast2-printer-2.18.15-2.23.x86_64
deinstallation of yast2-nis-client-2.17.7-2.19.x86_64
deinstallation of yast2-mouse-2.18.0-2.23.x86_64
deinstallation of yast2-network-2.18.30-3.15.x86_64
deinstallation of yast2-storage-2.18.12-1.6.x86_64
install satsolver-tools-0.14.1-60.1.x86_64 (with vendor change)
openSUSE
-->
openSUSE Build Service
Solution 2: do not ask to install a solvable providing zypper >
1.0.9-0.1.1

Choose from above solutions by number or cancel [1/2/C]:

< Previous Next >
This Thread
  • No further messages