Mailinglist Archive: opensuse (1468 mails)

< Previous Next >
Re: [opensuse] Relative number of users of OpenSuse 11.0 vs OpenSuse 11.1?
  • From: "David C. Rankin" <drankinatty@xxxxxxxxxxxxxxxxxx>
  • Date: Sat, 6 Jun 2009 14:53:37 -0500
  • Message-id: <200906061453.38200.drankinatty@xxxxxxxxxxxxxxxxxx>
On Friday 05 June 2009 22:06:34 Andrew Joakimsen wrote:
My main machine I upgraded openSUSE 11.0 -> 11.1 without any problems.
There were issues with the ATI drivers that caused me to do a clean
install, but that did not resolve the issue. So I lived with jerky
screensavers for about a month and now the newest ATI driver in the
repository doesn't lock up the machine!

On Fri, Jun 5, 2009 at 19:14, Dan Kegel<dank@xxxxxxxxx> wrote:
I'm trying to decide whether depending on LSB 3.2 is going to
cut out a lot of users. How far along are folks on moving to
OpenSuse 11.1? Or are a large fraction of users still on older
versions of OpenSuse? Are these statistics available anywhere?
Thanks,
Dan

Andrew hit the nail on the head!

If you have an older ATI card (older than the 2400 Series), then you no
longer have driver support from ATI. ATI dropped all support for all users of
*all* previous cards.

The problem is that on many of the older *legacy* cards, the last
working
driver was the 8-9 release (Ver. 8.532) which has no support for xorg 7.4 (the
version packaged with 11.1). On many older cards the 8-10 through 9-3 (the
last driver with legacy support) drivers simply "do not work."

For example, (my situation) if you have ATI hardware that doesn't work
with
the 9.3 driver -- you are hosed and you are stuck using 11.0 until you upgrade
your graphics card. Otherwise, you will have *no fglrx* driver to use in 11.1.
If you have a laptop -- you are just hosed. You must stay with 11.0 or upgrade
and switch to the radeonhd driver.

The radeonhd driver is getting much better and works fine, but face it,
performance is still about 20-50% of what you get with the fglrx driver.
Additionally, for laptop users, the downclocking/powerdown capabilities of the
radeonhd driver are still in work and the lack of downclocking can cause your
laptop to run extremely hot -- solely due to the heat produced by the ATI gpu
without the proprietary downclocking and unused chip circuitry powerdown
provided by the fglrx driver.

Running the radeonhd driver on my Toshiba laptop causes such extreme
heat
production, I can fry eggs on the palm rest. (literally, I have to lift my
hands off the palm rest continually to avoid the heat: 96-97 deg. F palm rest
temp and Left Fan Discharge: 147 Deg. F) [The left fan discharge is just below
the palm rest] That's with:

Option "ForceLowPowerMode"
Option "LowPowerModeEngineClock" "140000"

Using the fglrx driver, there is no heat problem on the palm rest and
the
Left Fan Discharge temp drops to 122 deg. F. (That's a 25 deg. F drop just due
to gpu chipset power control)

So for my laptop situation, with a legacy card that will not work with
the
9-3 release, I am stuck using 11.0 until EOL, and by then I will have a new
laptop with an NVIDIA gpu in it.

With that background, the answer to your question is simple. If you are
not
affected by a hardware issue that requires you stay with 11.0, then by all
means run 11.1. If you are stuck running 11.0, you can still install the
latest and greatest KDE desktop, and all of the other latest apps. So the
actual "difference" between running 11.0 or 11.1 to the end user is nothing
more than a kernel version difference. If your hardware doesn't require any
new feature only available in the 11.1 kernel, then the release choice really
becomes a "who cares" issue aside from the EOL support time remaining. (which
is in itself is increasingly more of a "who cares" issue due to bug fix times
and priority)

So check your hardware, pick a release number, pop the DVD in the tray
and
reboot ;-) Both 11.0 and 11.1 are fine (10.3 still works great for that
matter)


--
David C. Rankin, J.D.,P.E.
Rankin Law Firm, PLLC
510 Ochiltree Street
Nacogdoches, Texas 75961
Telephone: (936) 715-9333
Facsimile: (936) 715-9339
www.rankinlawfirm.com
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >