Mailinglist Archive: opensuse (1468 mails)

< Previous Next >
[opensuse] What is wrong with my NX server?
  • From: Joop Beris <opensuse@xxxxxxxx>
  • Date: Thu, 04 Jun 2009 11:20:45 +0200
  • Message-id: <55b9e7c6c22882d305bd4487f2069bb6@xxxxxxxx>
Hello listmates,

I have recently installed NX server, after switching to openSUSE 11.1.
However, I can't seem to log in. It used to work beautifully on openSUSE
10.3.

What I did is the following:
- First of all, to install the NX server, I added the following repository:

http://download.opensuse.org/repositories/X11:/RemoteDesktop/openSUSE_11.1/
From that
This resulted in the following packages being installed:
- FreeNX
- NX
- freenx-client
- libnxcl1

- After that, I ran nxsetup, which completed without errors.
On the client, I installed version 3.3.0-6 of the NX Client for Linux from
NoMachine. I chose this client because in the past, I have had bad
experiences with the FreenNX client. The NoMachine client has always worked
well for me.

- Trying with the QtNX client, the client simply seems to freeze, without
doing anything after starting the connection.

- Up launching the NX client and entering the connection details, I start
the connection. This takes a while, after which the client responds with:
"Session startup failed". In the detail window, it says a lot more:

NX> 105 /usr/bin/nxserver: line 1371: 13828 Terminated sleep
$AGENT_STARTUP_TIMEOUT
NX> 596 Session startup failed.
NX> 1004 Error: NX Agent exited with exit status 1. To troubleshoot set
SESSION_LOG_CLEAN=0 in node.conf and investigate
"/home/<user>/.nx/F-C-<hostname>-1000-8689F93F7362B387803D3B292867F08C/session".
You might also want to try: ssh -X myserver; /usr/bin/nxnode --agent to
test the basic functionality. Session log follows:
Can't open
/var/lib/nxserver/db/running/sessionId{8689F93F7362B387803D3B292867F08C}:
No such file or directory.
mv: cannot stat
`/var/lib/nxserver/db/running/sessionId{8689F93F7362B387803D3B292867F08C}'NX>
1006 Session status: closed
: No such file or directory
NX> 280 Exiting on signal: 15

FOllowing the troubleshooting advice above, I have set SESSION_LOG_CLEAN=0
in /etc/nxserver/node.conf
I also tried the command "ssh -X myserver; /usr/bin/nxnode --agent" to test
the basic connection from the client. This gives me the following error on
the console:

NX> 1000 NXNODE - Version 2.1.0-72 OS (GPL, using backend: 3.2.0)
NX> 716 Starting NX Agent ...
Error: Aborting session with 'Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again'.
Session: Aborting session at 'Thu Jun 4 11:07:26 2009'.
Session: Session aborted at 'Thu Jun 4 11:07:26 2009'.
NX> 716 NX Agent exited with status: 1
NX> 1001 Bye.

I find this odd, since to me this seems to be a problem with X
authorization, not something to do with NX. I have confirmed that while X
(KDE) is running, no one is logged into the machine at this point.

I have also investigated
/home/<user>/.nx/F-C-<hostname>-1000-8689F93F7362B387803D3B292867F08C/session,
to see if there is some more information there. There, it lists the
following:

NXAGENT - Version 3.2.0

Copyright (C) 2001, 2007 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Agent running with pid '15613'.
Session: Starting session at 'Thu Jun 4 11:14:43 2009'.
Info: Proxy running in server mode with pid '15613'.
Info: Waiting for connection from '127.0.0.1' on port '5000'.
Info: Aborting the procedure due to signal '15'.
Error: Aborting session with 'Unable to open display
'nx/nx,options=/home/<user>/.nx/C-<hostname>-1000-8689F93F7362B387803D3B292867F08C/options:1000''.
Session: Aborting session at 'Thu Jun 4 11:14:43 2009'.
Session: Session aborted at 'Thu Jun 4 11:14:43 2009'.

I enabled logging in /etc/nxserver/node.conf, and the same information is
logged there.

I am a bit stumped as to what to try now. Does anyone have any suggestions,
please?

I'll be grateful for any help or tips which help me solve this.

Kind regards,

Joop
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups