Mailinglist Archive: opensuse (1695 mails)

< Previous Next >
[opensuse] Re: Problems with resize2s [was: Problems growing a logical volume with LVM tools.]
  • From: "Ciro Iriarte" <cyruspy@xxxxxxxxx>
  • Date: Wed, 24 Sep 2008 12:13:59 -0400
  • Message-id: <a998a0140809240913w577eabe3q8732f719cd6c644c@xxxxxxxxxxxxxx>
2008/9/23 Vinai Roopchansingh <vroopcha@xxxxxxx>:
Ciro Iriarte wrote:

2008/9/21 vinai <vroopcha@xxxxxxx>:

On Sat, 20 Sep 2008, Ciro Iriarte wrote:

snip...

Can you post this info?:

- parted -l /dev/sdc

Model: AMCC 9500S-8 DISK (scsi)
Disk /dev/sdc: 7000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number Start End Size File system Name Flags
1 17.4kB 2800GB 2800GB primary , , , , , lvm, , ,
, ,

... [Lots of output from pv/vg/lg display snipped]

Parted only states 2800GB for /dev/sdc1.... How did the PV accepted to
grow?, probably that's the issue... You should change the partition
table resizing sdc1 (then running pvresize), or create sdc2 as a new
PV with the rest of the space...

As an alternative, you can use the whole sdc disk without partitions,
that way you can avoid the partition resizing step in case you keep
growing the underlying raid. Not sure about how this will affect the
LVM auto discovery process (no partition type to look for).

This was the problem - thank you Ciro. I don't know how pvresize took the
argument for the increased disk originally, but it did.

I tried to resize the physical volume with parted, but that did not work
either. However, I created a 2nd partition in the expanded space. I made

Reading the documentation "parted /dev/sdc 1 17.4kB 7000GB" should do
the work, but I didn't test it..

the 2nd partition a physical volume, added it to the volume group, and was
successfully able to grow the logical volume to the full disk size:

# lvextend -d -v -l 1668910 -n /dev/array2/rd2
Finding volume group array2
Archiving volume group "array2" metadata (seqno 3).
Extending logical volume rd2 to 6.37 TB
Creating volume group backup "/etc/lvm/backup/array2" (seqno 4).
Found volume group "array2"
Found volume group "array2"
Loading array2-rd2 table
Suspending array2-rd2 (253:0) without device flush
Found volume group "array2"
Resuming array2-rd2 (253:0)
Logical volume rd2 successfully resized

However, there is one last issue. The resize2fs tool does not want to grow
the filesystem beyond 4.3TB. I was able to run:

# resize2fs /dev/array2/rd2 4300G

With a FS of that size, probably you use big files and probably
(guessing again) you'll be better with XFS anyway


successfully, but with no argument (original attempt) or anything else
beyond that size, I get the message:

# resize2fs /dev/array2/rd2 5100G
resize2fs 1.40.2 (12-Jul-2007)
Resizing the filesystem on /dev/array2/rd2 to 1336934400 (4k) blocks.
resize2fs: Memory allocation failed while trying to resize
/dev/array2/rd2

I think this is specifically a bug with resize2fs, as I was able to create
larger filesystems with mkfs. I tried growing the partition by smaller and
smaller amounts, but it seems I could not grow the file system beyond that
size. Where can I file this bug to the ext2/3 tool set ?

Will, this is the place to go: https://bugzilla.novell.com/enter_bug.cgi


Thanks again all for helping me get this far.

I'm glad it worked


cheers
vinai


Regards,
Ciro
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >