Mailinglist Archive: opensuse (1695 mails)

< Previous Next >
Re: [opensuse] Problem using YAST to remove a package
  • From: Clayton <smaug42@xxxxxxxxx>
  • Date: Sun, 21 Sep 2008 09:07:19 +0200
  • Message-id: <e29967880809210007m250b3f57h229b7a169609b2c5@xxxxxxxxxxxxxx>
I've been puzzling over this one for a while now. In the YAST package
manager, I can see that it thinks the package names strigi is
installed. If I mark it for removal, I get this error message back:
===============
2008-09-19 17:32:28 strigi-0.6.0-15.2.i586
rpm output:
error: package strigi-0.6.0-15.2.i586 is not installed
===============

If I drop to the command line, and type:
rpm -qa strigi*
I get no results back... which tells me that strigi is probably not
installed.

So.. why is the YAST package manager reporting that strigi is
installed? have I missed the obvious yet again?

I would rebuild the RPM atabase from a root CLI and without YAST open
and see if that solves the issue.

I could have sworn I had done an --rebuilddb at some point while I was
poking around to figure this out... anyway, it worked this time. rpm
-vv --rebuilddb (-vv so I could watch what was happening) cleared it
up, and now both rpm at cli and yast know that strigi is gone.

C.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
References