Mailinglist Archive: opensuse (1695 mails)

< Previous Next >
[opensuse] Problems growing a logical volume with LVM tools.
  • From: Vinai Roopchansingh <vroopcha@xxxxxxx>
  • Date: Fri, 19 Sep 2008 13:46:31 -0500
  • Message-id: <48D3F387.6070108@xxxxxxx>
Hi Folks,

I've been using SuSE and openSUSE for a little while now, but this is my first foray into LVM.

First off - the setup is a 4U rack-mounted server running openSUSE 10.3 64-bit, with all updates installed. There are 16 hard drives are split up into 2 8-disk RAID-5 volumes using a 3ware hardware SATA controller card. Each volume was made up of disks that were previously 400 GB, but now upgraded to 1 TB, hence the total volume size grew from 2.4 TB to 6.3 TB. The initial setup on this machine did not include LVM, and I would like to implement it to handle future size increases. Bot I am stuck at the final step of extending the logical volume. Here's what I did so far:

- On the 6.3 TB RAID-5 volume, I created a partition (with parted, type GPT, with the lvm flag on). This partition was 2.4 (or thereabouts) in size, to simulate the growth from 2.4 to 6.3 TB (we were previously able to grow the underlying RAID-5 volume successfully).

- I made this partition (sdc1) a physical volume.

- I then made a volume group (array2) from this single partition

- After that, I made a logical volume (rd2) from the array2 volume group

- I used parted and mkfs on this logical partition (rd2) to create a partition with the "loop" label and format it.

- I put some data on there and ran a checksum.

- Then I unmounted the rd2 logical partition from the computer's file system.

- I ran pvresize on it and maxed out the number of extents available on the physical volume successfully.

- I repeated the same for vgresize successfully.

- And finally (or so I thought) I ran lvextend to resize the logical volume. But here's where I ran into issues. Here's the command I've been trying and the output:

# lvresize -d -v -l 1668910 /dev/array2/rd2
Finding volume group array2
Archiving volume group "array2" metadata (seqno 4).
Extending logical volume rd2 to 6.37 TB
Creating volume group backup "/etc/lvm/backup/array2" (seqno 5).
Found volume group "array2"
Found volume group "array2"
Loading array2-rd2 table
device-mapper: reload ioctl failed: Invalid argument
Failed to suspend rd2

The size of the logical volume does not change. I even tried this using the GUI in YaST2, but the error message that popped up was essentially the same thing. What did I miss, or what I am not doing ? I got the same results with "lvextend" ...

Thanks all.


To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >