Mailinglist Archive: opensuse (1695 mails)

< Previous Next >
[opensuse] 11.0 YAST->Network Device; 'Skip Refresh' button UnReachable on Failed Repo Refresh
  • From: "David C. Rankin" <drankinatty@xxxxxxxxxxxxxxxxxx>
  • Date: Wed, 17 Sep 2008 11:43:07 -0500
  • Message-id: <48D1339B.3080207@xxxxxxxxxxxxxxxxxx>
Listmates,

I have filed the bug report, but wanted to compare notes with the
brain-trust
first. In Yast, Network Devices, during the hurricane, I needed to change both
the wired and wireless cards from dhcp to static IPs. Simple enough. However,
after finalizing the settings and clicking 'Finish', Yast blunderingly tried to
'refresh' all online software repositories which of course failed forcing _14
repetitions_ of (repo timeout; 'Skip'; 'OK'). Notwithstanding the open question
of "Why must yast force a refresh just to change a single IP config?", yast's
most frustrating bug was that it provided no way to avoid looping through every
single failed repo to both ('Skip') and confirm the skip ('OK') on each
iteration. All seemed very unnecessary just to change a network setting.

After clicking "Finish" and being bombarded with 14 failed online repo
updates, I noticed that Yast's "Abort" button had changed to "Skip Refresh",
and a subtle smile crept onto my face. Ah hah, the Yast devs were thinking
ahead and had addressed just this situation I thought. But to my dismay, the
"Skip Refresh" button was unreachable? No, I though, surely not! But try as I
may, there was no way to actually click the button. Failed logic had reared its
ugly head again.

So I thought I would test this blunder vigorously to really try and
figure out
what the devs had done with this mysterious "Abort/Skip Refresh" button. So I
tried:

(1) making changes; clicking "Finish"; and immediately clicking in-the-blind,
where the "Skip Refresh" button would appear -- only resulted in the repo
failed dialog ('Retry' 'Abort' 'Skip') beating me to the punch;

(2) with the repo failed dialog staring me right in the face, and looking right
at the "Skip Refresh" button sitting smugly below on the main network device
dialog, I tried clicking the failed repo dialog "Skip" button and then
immediately clicking the "Skip Refresh" button -- no dice, the confirming
dialog for the repo failed ('OK') again beat me to the punch.

(3) I attempted the same thing after clicking 'OK', with the same result. Yast
at that point, looped into trying the next on-line refresh causing the next
failed/Skip/OK iteration.

No matter what I tried, the "Skip Refresh" button was unreachable. It is
apparent that someone within the yast dev group has tried to address this nutty
"forced refresh on network device change" situation to attempt to give the user
an out -- skipping the repo refresh, which in many situations, it should be
obvious that no internet access would be available to the user or wanted.

The problem seems obvious. The refresh repo loop appears to never
release
control to allow a "Skip Refresh" or to check for a "Skip Refresh". It seems
that the "Skip Refresh" does not need to simply replace the "Abort" button on
the main network device window, but needs to be moved to the repo-failed dialog
so that it can be accessed by the user.

Has anyone else experienced this? Moreover, has anyone else been able
to reach
the "Skip Refresh" button while performing a network card setting change? If
you would like to add your ideas, the bug is:

https://bugzilla.novell.com/show_bug.cgi?id=427017


--
David C. Rankin, J.D., P.E.
Rankin Law Firm, PLLC
510 Ochiltree Street
Nacogdoches, Texas 75961
Telephone: (936) 715-9333
Facsimile: (936) 715-9339
www.rankinlawfirm.com
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages